5G not working on T-Mobile

necrosdantenecrosdante Level 1
edited December 2020 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ZS661KS
  2. Firmware Version: 17.0823.2009.98
  3. Rooted or not: No
  4. Frequency of Occurrence: Constant
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

So my phone is in the current firmware update and security update. I even went as far as getting a newer Sim card and I still can't access 5G which is plentiful in my area. I think I saw the 5G icon pop up once but that's when I first set up my phone. After a couple of updates I can no longer access 5G mobile connections. Anyone else having this issue? This is my first time getting a gaming phone and I'd hate to have buyers remorse over something like not being able to use all the functions that come with the phone

Comments

  • Looks like you are on WW firmware. Most likely ASUS has not added support for tMobile. But make sure you check with carrier to ensure it's enabled for you or can be enabled (not all carriers support 5g bands of this phone). A lot of buyers remorse for all of us in here atm tbf. If your comfortable with rooting and unlocking, head to XDA Developers as there is better support over there.

This discussion has been closed.