Battery Usage Graph Problem

AirJoeAirJoe Level 1
edited October 26 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: ASUS ROG Phone 2
  2. Firmware Version: WW-17.0240.2009.49
  3. Rooted or not: No Root
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app):

My battery usage graph display error as above screenshot. I try to charge battery to 100% and the graph will reset to normal. However when I reboot device or power off device, this graph will return to this error again. As you can see it counts from 33 days ago from now. Yesterday it was counted from 32 days ago. Which means it always count from 23-Sep. I didn't do factory reset because I don't want to lose my data. And the actual battery usage is fine. Anyone here know how to fix this? Thanks!!

Comments

  • AirJoeAirJoe Level 1

    I try to discharge battery until it turn off itself and then charge to 100% when phone off. The battery usage graph back to normal.

    When I reboot my phone, it count from 33 days ago again. What happen to it? Which system apps I need to clean cache to reset it to normal?


  • edited October 30

    Wow, this was a weird one. I will check with my colleagues if there's any way to reset your battery stats without doing a factory reset. Have a nice weekend!

  • Maybe I could suggest something like a "clear cache" or something of some sort? People who don't charge their phone to 100% has something like this (until they charge it to 100%)


  • AirJoeAirJoe Level 1

    Thanks for your advise. I agree charing up to 90%-100% will temporarily solve the problem. However when I reboot my device, it will count from 33 days ago. I usually charge up to 80% for better battery lifespan.

    I try to clean all cache from Asus Mobile Manager. Unfortunately it didn't help. As you can see the first post at the top, if I don't charge it up to 90%, the actual usage will only show at the right side. If I didn't reboot for one week, the actual usage will compact at the right corner because the entire graph will always count from 33 days ago.

    I wish Asus can fix this in next update, I know this is very strange problem happen on me but not most of user.

  • AirJoeAirJoe Level 1
    edited November 1

    After 2 days of use and I reboot my device again, the graph now counted from 39 days ago. According to my record, it was 23-Sep again which was the date I updated bugged firmware 17.0240.2009.47. I think this problem is came from this firmware. Although I am already in 17.0240.2009.49, that might be leftover bug still not yet fix. I wish Asus can investigate this and advise solution. Thanks Asus!

  • I asked our devs to have a look at this thread and they need to see a log from your device to determine what went wrong. They said this might even be due to a hardware issue.

    I will send you a PM with log instructions

  • ronald1985ronald1985 127.0.0.1 Level 4
    edited November 22

    So I had this problem after 6 days. I was draining the battery at 120hz screen refresh and I had X mode on but these settings could be a red herring.

    I then charged (not hypercharge) from 0 percent to 100 percrnt with the phone still turned off. Once you are at 100 percent, while leaving the phone on charge, turn on the phone (at this time, battery stats didnt reset for me). Let it continue to charge for another 10 minutes (without Battery Care) and then disconnect charger.

    The only reason I can think of for this happening is the battery stats in the root storage is out quite a bit and when you charge, you are not hitting that 90 percent which is meant to reset the battery stats.

Sign In or Register to comment.