Rog 2 Latest Update WW.17.0240.2009.49

IgneelIgneel Level 1
edited November 12 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: Rog 2
  2. Firmware Version: WW.17.0240.2009.49
  3. Rooted or not: Not rooted
  4. Frequency of Occurrence: Very frequent
  5. APP Name & APP Version (If your issue relates to the app): NA

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Hi Mods, this is my first post and it sucks that it had to be about an issue that I have been facing since the new update came out.

Before all this update fiasco, my phone was in the RMA process for 4 months from May till end of September this year. It was RMA to fix a cracked LCD. It was at the version just before .49 and I didn't have any temps issue. One night, my phone auto updated itself and here I am. It's been more than a week and still the same issue persist. I have factory reset twice! Send help please 😭

I don't think I can RMA it again and wait that long since my set is a Malaysia set and I live in Singapore. Due to covid-19 Malaysia's borders are still closed. It'll be another 4 months if I RMA again😭

The problem: My cpu is going from 826Mhz to 2.96Ghz and my Gpu is going from 585 to 800+. The temps for my cpu are 45°C to high 50°Cs all the time at idle. My Gpu is in the 40s°C at idle. The coolest my phone will be is at 40-45°C.

As a result, my battery is suffering and I'm pretty sure my chips are being degraded faster.

Usage Scenario: I haven't played any games at all since I got it back since I've been busy with work, so it was mostly just WhatsApp, Youtube Vance, Emails, Edge browser and Tachiyomi.

I'm using my phone on 60Hz, Wifi at home and Mobile data at work. I have Blockada running all the time with only energized blu selected, it barely does anything to the battery.

This is my phone at it's "coolest" literally idling.

This is my phone when it's pegged at 2.96Ghz.

These are the running processes in developer options.

This is my battery usage. My battery so far is not bad but not great either.

Mods please help and contact me if you need more info. I know this update was supposed to fix this specific issue but hey I drew the short end of the stick and it brought me this issue.

@Gustav_ASUS

@ARP_ASUS

Comments

This discussion has been closed.