Battery health charging integrated on the MyAsus app is not working

briantinantobriantinanto Level 1
edited December 2020 in Others

I've recently came across a problem with the battery health charging on the MyAsus app. I've set it to maximum lifespan but for some reason everytime i shutdown or restart my laptop, the battery keeps charging above the set maximum charge which is 60% for maximum lifespan. Any clue on how to fix this, thanks in advance

«1

Comments

  • Hello Brian,

    Please kindly understand that My ASUS is an APP, which is only functioning when you enter or working under Windows system.

    So there is a time period between booting up to entering OS, the APP can't help to control the charging.

    This does not affect regular daily usage.

    Thank you.

  • CzgergoCzgergo Level 1
    edited October 2020

    I noticed exactly the same problem 1 or 2 weeks ago.


    Charging in my UX433FA with Win 10 Enterprise does not stop automatically at the threshold set in My Asus. It worked perfectly for almost a year, and suddenly went wrong. I re-installed My Asus, but it did not help. I also added My Asus to the automatc start-up list in Windows. Even though it starts automatically it does not limit charging only if I change the setting and then put it back to Maximum Lifespan. It is getting more and more annoying, and I assume this method does not work if I connect the charger when the laptop is off. I am really keen to maximise the lifespan of my battery, so plese let me know how to fix this issue.

  • CzgergoCzgergo Level 1
    edited October 2020

    Dear Blake, waiting does not help. I tested many scenarios, but the only way to limit charging below 100% is to run My Asus, set to a random limit, and then back to Maximum lifespan mode.

  • Hello Czgergo,

    I'm sorry that we can not guarantee the APP performance under Windows Enterprise version.

    and can't not do much about it.

    The structure and rule for APPs under Windows Enterprise version are really different from Home and Pro, which are sometime more limited.

    Thank you.

  • CzgergoCzgergo Level 1
    edited October 2020

    Dear Blake, many thanks, but how is it possible that the app worked perfectly until 3 weeks ago under Win 10 Enterprise, and then suddenly stopped working. I suspect this is nothing to do with the version of my Windows. I actually cannot install the Pro version as this is a managed PC.


    Please let me know how can I investigate why is the Battery Health Charging function does not start automatically with Windows startup. I had to add My Asus to the automatic startup list to at least have the chance to limit charging manually. If I start the app manually and change the setting to something and re-set to the wanted setting, it works. I also checked that if I shut down my system in a way that Battery Health Charging was running before, charge settings remain active even after unplugging/ replugging the charger.


    I have seen some very recent comments in similar topics so I think there may be a general issue with Battery Health Charging so I would appreciate if you could report /investigate it.

  • Hello Czgergo,

    I'm really sorry that as long as it is under Windows Enterprise version, we can not help much.

    Maybe something change in the Windows 3 weeks ago?

    Thank you.

  • Dear Blake,

    I don't think that the best answer for your customer.

    I'm using the asus TUF and have a same problem.

    I uninstall myasus app in my laptop and reinstall again.

    The app working again, but when shutdows, this problem has been again.

    The problem has been over 1month and that terrible feel when using the official app in my laptop I trusted.

    Sincerely!

  • I have a Zen notebook running Windows 10 Home. I have experienced the same problem, starting around 3-4 weeks ago. In spite of the The Battery Health setting in MyAsus being set to Maximum Lifespan Mode, charging continues to 100%. It always used to stop charging at 59%. Even if I allow the battery to discharge then plug in the power again, it always goes back to 100%. This is definitely a change from the previous working state. Please fix this problem.

  • Dear Blake,

    It seems that the problem is not Win 10 version related (See Alex11's post), so please find the reason and Fix it ASAP. There are multiple complaints in related topics as well from different people.

    Many thanks!

  • Hello hle72893,

    Which model do you have extactly?

    Have you checked BIOS and ASUS system control interface driver?

    Thank you.

  • HelloAlex11,

    Which model do you have ?

    Have you checked BIOS and ASUS system control interface driver?

    Thank you.

  • Hello Czgergo,

    I will still have the same answer for you.

    I will go on to collect information from the others.

    Thank you.

  • Hello i also have this same problem on my Asus TUF FX505DY Windows 10 Home which also happen like 2 or 3 weeks ago and i've been browsing around and just found this thread. It seems like there's something to do with the application or windows update which cause this problem hopefully there's some kind of solution for this as for now i need to launch myasus and switch the mode to activate it on every startup

  • bardandrasbardandras Level 1
    edited October 2020

    I have the same problem which began a few weeks ago.

    My OS is Windows 10 Professional (x64) Build 19041.572, on a notebook ASUS TUF Gaming FX505DD_FX505DD

    Update: I found and downloaded the separate ASUS_Battery_Health_Charging_Win10_64_VER100002 app, installed and it works -- stops the charging at 60%.

  • Facing the same exact issue.

  • Dear all,

    Please kindly update ASUS System Control Interface V2 driver V2.2.31.0

    and REBOOT the device then reinstall MyASUS.

    Let me know the result.

    For FX505 series, there will be another new update for you, but still let me know the result of this version.

    Thank you.

  • hello thank you for the update by following your instruction now my battery health charging working as usual upon each login on my FX505DY. thank you again for the help, i will let you know if the problem still persist

  • Hi

    Model is UX433FA. I have ASUS system control interface driver version 1.0.31.0. I tried following the instruction to update to v2, but the V2 installation wizard said I did not have the right version? I also downloaded latest version of MyASUS as per the instructions and rebooted. So I am still on V1. What needs checking with BIOS? Note - the Battery health charging feature was working a few weeks ago.

    Thank you

  • Hello Alex11,

    Your model is supporting V1 driver only.

    Please kindly check if your BIOS is up to date,

    and the latest V1 driver is Version V1.0.33.0.

    So please update it and reinstall MyASUS as well.


    Thank you.

This discussion has been closed.