ROG Phone Camera Focus Issues

IcykoIcyko Level 1
edited November 2020 in ROG Phone


  1. Model Name: ZS600KL
  2. Firmware Version: PKQ1.Q90101.001.WW_Phone-16.0420.2006.30
  3. Rooted or not: Not Rooted
  4. Frequency of Occurrence: Since 9/6/2020
  5. APP Name & APP Version (If your issue relates to the app): Camera, Ver 5.0.71.0_200117

========================================

Hello,

I recently found that my phone's focus does not seem to focus on anything more than 6 inches away from the lens. I'm not sure when this issue started, but the last photo I took was from 9/6/2020. I tried using the manual zoom, and while the focus does seem to change, it still is unable to focus on things in the distance. This issue occurs in other apps, as well as when using the phone in safe mode. I tried clearing the data and cache on the camera app to no avail. Any ideas on fixing this?

Attached is photo out of focus. I also have a link to a video on dropbox messing around with manual focus, but I cannot post links yet:


Comments

  • Hi bionicle.co

    Thank you for your asking. Because you already tried safe mode, clear cash and data, please try some other troubleshooting tips below:

    1. "the Factory Reset" 

    Settings>System>Reset options>Erase all data(factory reset)

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

    2. Please check on SMMI test 

    Calculator> type ".12345+=">SMMI TEST>Single Test>Camera Capture Test

    If any of the SMMI tests fails, indicating high possibility of faulty hardware, kindly bring your device to the nearest ASUS repair center for device checking: https://www.asus.com/support/Service-Center-All-Countries/

    If it is impossible to access the service center during Covid-19 period, please try Call us: https://www.asus.com/support/CallUs

  • If you still face this problem, maybe you need to upgrade your phone. Of course, we have Asus ROG Phone 3. It will offer a better service than this first series.

    PS: We no longer care about user questions on this Asus ROG Phone. We are totally concentrated on our latest mobile :)

  • Ok so I tried the SMMI Test and all my camera test failed, despite the wide angle and front facing camera seeming fine. It seems that there may be some QR I need to try and scan in order to pass the test.

    I use my phone a lot, so I didn't want to factory reset it and deal with data restoration and transfer. I stumbled upon an article that suggested I hit the camera. I gave my phone a good smack on the top edge and the main camera appears to be focusing correctly now. I have no idea what the issue was or why that worked, but I'm glad I don't have to replace my phone yet. Hopefully this can be helpful to anyone else who may have this issue too.

This discussion has been closed.