Armoury Crate Service Error

  1. System: Windows 10
  2. Battery or AC: Battery
  3. Model: ROG Strix G531GT
  4. Frequency of occurrence: -
  5. Reset OS: -
  6. Screenshot or video:

========================

Detailed description:

Hi, I cannot my use my Armoury crate as usual, its been 3 days and keep counting. It shown "Service Error" when trying to open Armour Crate. Im trying reinstalling but the error always pop up. It stated that Rog Live Service, Aura Service, and Armoury Crate service not installed, but when i open Program and Features its already installed *picture Attached*.

What whould i do?


Comments

  • Ya the I'm facing the same problem from past three days i have been reinstalling it everyday but showing the same troubleshoot problem I don't why its happening


  • yep 3 days since the problem started, I'm also using ROG Strix G531GT

  • I use the same model and the same stupid problem with armoury crate

  • nostromovnostromov Level 1
    edited September 20

    ASUS TUF FX505DU laptop and Armoury Crate will NOT run. I can get it to load when running some installer for it (there are like 1,000,000,000 different ones, not sure which one it was) and then selecting to open, or run from its final menu and then that's it. The next time I want to load it from Windows, it's a no go. Why do I get the feeling that this is the start of a battle that many of us are going to lose. :/

    Windows 10 Enterprise LTSC (64-bit, ofc.)

    EDIT: This screenshot is all I see, before it goes down, no error logged in Event Viewer:


  • same problem here, keyboard lights are not working anymore

    model: g531gt

  • nostromovnostromov Level 1
    edited September 20

    OMG., I think I get it. In the template to post to the forums, it says: "5. Reset OS?"

    This software, Armoury Crate, is a "Trusted Microsoft Store app". That's the problem! You don't design software for the MS Store, it is literally THE WORST. Guys, that's the bad news: it is NEVER going to work (again) until:

    1) ASUS come to their senses and re-program their software (from the ground up) to be normal, or

    2) we destroy our Windows installation and setup, in order to regain this functionality.

    So, so stupid. Unbelievable.


  • i got rog strix g731u and have the same problem.

  • edited September 21

    Dear all,

    Thank you so much for your feedback,

    May I have the version of your BIOS, Windows, Amoury Create Service,ASUS System Control Interface V2 and ROG Live Service Package?

    I have reported this issue to related department.

  • Hello Blake_Asus

    Bios Windows

    Armoury crate service not installed.

    ASUS System Control Interface V2.2.28.0

    ROG live Service 1.1.6.0

    Please fix it soon. Everyone looks like facing the same problem with me.

  • Hello @[email protected] ,

    Thank you so much for the information.

    Is your OS from factory? or you have installed your own one?

    Also, may you tried to uninstall all drivers and follow below FAQ to install them back again?

    Please be careful that the installation order must be the same.

    Thank you.

  • edited September 21

    Hello @Blake_ASUS

    Thank you for suggestion, OS is from factory.

    I try all the steps and error message not pop up anymore.

    It seems be an old version of armoury crate and trying to update by itself, but always "Waiting on Updates".


    What should i do now?

  • Hello @[email protected] ,

    And the Armoury Crate is updated back to 3.1.5.0?

    If not, I would recommend to stay in current status before our designer find out more of this issue.

    Keep me updated. Thank you so much!

  • Hi Guys, its looks work for me.

    Using procedure by @Blake_ASUS but i change the order between install armoury crate service first to 2nd order. So Armoury Crate>Armoury Crate service> the rest same..

    if still not working, try to open again armoury crate service then choose remove armoury crate service then restart your pc. Open again armoury crate service then choose install. After restarting, it look normal for me and can use any feature.

    @Blake_ASUS it seems work for me. but i dont know for a long time.

    now my armoury crate version are 3.1.5.0. please update the app for better stabilization. Since ROG laptop without Armoury Crate is nothing, we really depends on this app. please fix it.


    thank you. i will update soon if any error occur.

  • Before Instaling Armoury crate Armoury crate service etc, did you have to uninstall all of them before?

  • harshitpandya87harshitpandya87 Level 1
    edited September 25

    Hey there i need urgent help i am frustrated with this problem any one can help me why armoury crate is not working i tried everything even resetting the laptop but after when it completely updated i doesn't even recognize its own services running or not i am using ROG Strix G531GT. This is crazy its been 2 month since i purchased this laptop and after false update that asus provides its gives the same service error. When i contacted asus service they told something we can't do anything from there and recommended to take services which are ofcourse not the doorstep service. Can someone help me with this thing that why it forgets that system uses the services and gives the error?


  • yes i tried your steps as well it was not working after restart and installation again now somehow its works good automatically but its missing game visual and i don't know where can i find it everything is up to date still no sign of gamevisual.

  • Hello @harshitpandya87 ,

    This issue has been under investigation.

    I have PM you.

    Please kindly check an try.

Sign In or Register to comment.