Seeing "Some functions cannot be used, please restart the application or the computer" in MyASUS

BNibirBNibir Level 1
edited January 24 in VivoBook

I am having issues in MyASUS app. Because of this I am not able to use any hot keys such as pressing f2 and f3 for volume changes and so on. Not able to activate any features in MyASUS such as eye care, Battery charging mode, True to life etc. I tried restarting my PC and repair, reset and reinstalling the app and it didn't work. Searched in online for help, found something which says to update the driver "ASUS system control interference V2". Tried updating it but it was already updated. No pending windows updates😔

  • Device name and model: ASUS VivoBook S15 S531FL
  • OS: Windows 10 home

I am having this issue from 8 Sep 2020. It was all okay when I used my laptop and normally shut it down. But after couple of hours when I turned it on I am having this issue.

PLEASE HELP ME😭

Comments

  • Hello BNibir,

    Please uninstall MyASUS APP.

    Then update "ASUS System Control Interface V2" driver.

    Then install MyASUS App from Microsoft store.

    Thank you.

  • Hi. I have done this, reverted it to the previous driver, and also updated the driver again. All three attempts did not work. I am still seeing this message on top of the Home page of MyASUS. Any other troubleshooting steps I can perform? Otherwise I will just remove this app altogether. I do not wish to reset my Windows just for this app.


  • Hello Mikko,

    Please uninstall My ASUS

    then reinstall or update "ASUS System control interface V2"

    then install MyASUS back.

    Thank you.

  • I love the idea and the simplicity of those steps - but they simply didn't work. I tried 2 versions of drivers, numerous reboots at every steps - total uninstall of the Control Interface. No dice. Still have the annoying "Some things may not function......" banner on the MyAsus application. All this after a fresh install of Win10, all of the drivers....etc. Everything works great - except Asus' app. :-(

  • MonishaMonisha Level 1
    edited October 2020

    I'm having the same issue too after a fresh reinstall of Windows 10, any advice please?

  • Hello timlytle and Monisha,

    May I know which model you have? and the current version of your My ASUS APP and ASUS system control interface V2 driver?

    And fresh install of Win10 means you install another OS you own? not the factory one? which version is it?

    Thank you.

  • wefwqwefwq Level 1
    edited October 2020

    Hello.

    I'm having the same problem with MyAsus, this issue pretty much disabled Battery Health Charging function. After tinkering around, I have found the problem is that MyAsus program did not start "ASUSOptimization" service when user is logged on or during system startup.

    So when I tried to open list of service and start ASUSOptimization proecess myself, then open MyAsus program the message will disappear and my Battery Health Charging will be usable again.

    So that's said that this problem issue due to program not starting it's own service, anyone know how to make the service automatically run during startup? I have tried using Task Scheduler but no avail as I'm not tech-savvy enough.

    Any help will be highly appreciated.

  • Hey same device..same problem

    Did it worked out.. Or still same?

  • Hello wefwq,

    Which model and which version of ASUS System Control Interface V2 driver and MyASUS App you have?

    Thank you.

  • Hello.

    I'm using ASUS TUF FX505DD, with ASUS System Control Interface V2 v2.2.30.0 (2020/10/22), with MyASUS v2.2.44.0 from Microsoft Store.

    Asus Optimization service did not run automatically during startup, and will cause battery health function remain greyed out until I started the service manually.

  • Tyga909Tyga909 Level 1
    edited October 2020

    I can confirm this. Lighting and function keys do not work properly and you have to start this service manually to get everything working.


    Solution(Possibly): Download the largest MB size Asus System Control Interface V2 driver from the support page of your laptop on ASUS' website or the oldest one with the largest MB size. Uninstall all previous drivers. Turn network off so that windows doesn't update the driver and then unzip downloaded driver file and install. Then if it works, launch MyAsus and let it update drivers. I really hope this fixes it for you too.

  • Hi,

    PM has been send to you to check on few more things.

    Please kindly check.

  • I met the same issue as yours. i owned a G531GT.

  • Dear all,

    Please kindly update ASUS System Control Interface V2 driver V2.2.31.0

    and REBOOT the device the reinstall MyASUS.

    Let me know the result.

    Thank you so much.

  • My issue has been resolved with the latest update of ASUS driver from MS update & ASUS app from MS store (app version 2.2.49.0), Armoury Crate (app version 3.1.6.0), with ASUS System Control Interface V2 (v2.2.30.0), GameVisual plugin are now updated correctly (v1.0.9.0).

    ASUS Optimization service appear to be running automatically for every system startup, thank you very much for your help.

  • kenukikenuki Level 1
    edited November 2020

    hey there. i had the same issue. actually i had another issue before and then after fixing it, i run into this issue...

    im always on the latest drivers and apps. but one day suddenly the hardware status inside armoury crate stopped working. i read that uninstalling the armoury crate and its related services by using the uninstaller which comes shipped within the driver download zip from asus (not through windows software uninstaller) and then reinstalling them will eventually fix it. and it really did. hardware status was back.

    but then the issue described in this thread came up. i was on the latest version of everything, but still the Asus Optimization Service just does not want to start automatically. so i created my own fix:


    right click on desktop and choose new -> txt

    then paste this into it:

    net stop "ASUSOptimization"

    net start "ASUSOptimization"

    now click save as and name it FIXasus.bat and choose as filetyp below "other" (not .txt) and save it to desktop.

    now put it somewhere like "My Files"

    now create a shortcut to it and place it at "C:\Users\**Username**\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup"

    right click the shortcut and on the "Shortcut" tab click advanced

    tick "Run as Administrator" there

    save and reboot


    now every time windows 10 boots up, it will close the service and restart it.

    this way it will be loaded every time, even if asus delivers a fix in the meantime you can still leave it there, cause all it does is restarting the service manually.

    hope this will help someone :-)

    bye

  • Hi,

    Please kindly open another thread and specify your model.

    Thank you.

  • yyeah its work for me,but why this service stop running during reboot?

This discussion has been closed.