Laptop does not wake from sleep / frozen black screen - w/ Intel UHD Graphics 620 driver

ch2daych2day Level 1
edited November 2020 in ZenBook
  1. System: Windows 10
  2. Battery or AC: Both
  3. Model: Zenbook UX430UAR
  4. Frequency of occurrence: 50-60% of time when computer sleeps
  5. Reset OS: Yes, many times
  6. Screenshot or video: N/A

========================

Detailed description:

On Windows 10, I'm getting a black screen when trying to wake the computer from sleep or o just waking the display (if computer sleep is disabled).

The computer freezes completely and the only way to get it back is to power it down and back up. Occasionally (rarely), the keyboard will be lit solid or blinking in this frozen state. Also, the power led blinks .

If I leave the computer frozen for a long time it heats up considerably, especially if plugged in.

This is a work computer so no games and no overclocking. BIOS settings are defaults (BIOS has been updated to the latest patch, 308) .

Computer has been cleanly reinstalled a number of times and is currently on Windows 10 2004 with the latest patches.


Troubleshooting actions tried:


BIOS update to 308 (latest available)

Disabling all possible devices one-by-one in Device Manager (Wifi, BT, card reader, fingerprint reader, display audio, system devices, etc.)

Tweaking power options such as disabling sleep, hibernation.

Tested RAM and SSD OK - even tried a different SSD at one point.

Installing driver versions downloaded from ASUS website (chipset, graphics and others) for this computer (VGA labelled Coffee Lake) and for a very similar model UX430UA (VGA labelled Kaby Lake).

Trying different versions of Intel Graphics driver (UHD Graphics 620) from Intel website, ranging from version 21 to the latest available.

I've wiped and re-installed Windows clean already 6 or 7 times, to different versions, but the issue happens starts happening after the Intel driver is installed by Windows update.

BIOS was reset to defaults.

The only way I've found around the problem is to disable or uninstall the Intel driver, but that leaves me without brightness control, etc.

Please help!

Thank you in advance.

«1

Comments

  • That's incredible, your post might have solved the problem I've been having for a year now! I've been having the same problem where the computer doesn't come out of sleep mode and sometimes also overheats during sleep. Connecting devices via USB seemed to make the problem worse although it happened also with nothing connected.

    Up until now I was upgrading only drivers that were on the ASUS support website and the NVIDIA drivers. Following this post I upgraded the Intel graphics 620 driver (which I didn't realize I had) from 26.20.100.7372 to 27.20.100.8587 via the Intel website and the problem didn't happen for 3 days already, even with USB devices connected.

  • Hello ch2day,

    May I know what "the Intel Driver" it is and it's version?

    Thank you so much.

  • So I had a whole week without the computer getting stuck in sleep mode, then windows updated and now it's back.

  • What is the latest situation? i have the same problem

  • I have the same issue. However, I cannot seem to be able to predict when it happens. Sometimes it wakes up, sometimes it doesn't and I have to do a hard reboot.

  • Hi Halis,

    I have the IDENTICAL problem, to a tee, you are not alone!

    Seems like something ASUStek should help us with.

    S

  • we are waiting!!!

    What answer will come from Asus to this serious problem.

  • I have found a solution that has been working for the last 2 days.

    In the bios settings I turned OFF wake when lid opens (or something like that)

    Perhaps a conflict between who is responsible for waking BIOS or OS? Not sure but works so far.

  • Unfortunately this is a very elusive problem. At times I thought I solved it for a week or even a month and then it came back for no aparent reason. For the first half year my UXF533FD was bug-free, then this started happening. My first solution was to not connect USB devices when the computer goes to sleep. This worked for a very long period of time, failing only once a week or two or more (up to a month). Then after a while the frequency returned to once a day or more. Updates sometimes gave the impression of solving this problem for up to a week but then the computer relapsed again. Most recently, the latest large windows update and an intel graphics update both gave me high hopes only to fail after 3 days and a week respectively and go back to daily freezes.

  • same issue here for ux331un ..

    maybe try updating MEI driver to v 14 and see if it behaves differently. If not revert back.

  • I'm sure this is not what you guys want to hear but I had my motherboard replaced by ASUS and so far so good (5 days running without the issue).

    First they had reset my laptop to the factory OS image (with Windows 10 1809) and that didn't fix it, so I guess it wasn't a software/driver issue. But the motherboard replacement seems to have done the trick.

    Will update if things change (knock on wood).

    Good luck to all, including myself!

    bfn

  • HumaHuma Level 1
    edited September 2020

    In This Bios Settings I turned off wake when lid opens or something like that perhaps a conflict between who is responsible for waking BIOS or OS? Not sure but works so far

  • still going?

    could you take a picture of the motherboard or see if it's a new revision?

    wich MEI firmware do you have?

  • Sorry Red0X...I no longer have this laptop in my possession since I gave it to my son. He tells me he hasn't had any issues since the motherboard was replaced. Regular Windows updates (1909) have been applied. No special care with any drivers... :).

    So, it's a closed case from my perspective.

    Good luck.

  • Is there someone reading with a 430 or 331 zenbook with perfectly working sleep mode ? If so please could you post your :

    BIOS

    intel driver version

    MEI version

    MEI firmware

    Win version?

  • Downgarding my bios from 318 to 317 has permenently fixed this problem for me. Its been 10 days, all good. Interestingly when the sysem wakes there is a slight delay (<1sec) that was not present wit 318.

    Hope that helps.

  • tried also downgrade.. no change

  • I'm on a UX533FD and the wake-up problem happens with every BIOS I've had. It started happening when I still had 300 installed from the factory and continued when I upgraded to 304 and 306 (which is the latest version).

This discussion has been closed.