Mobile data internet is not working on Asusu Rog phone 3

edited January 20 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: Rog phone 3
  2. Firmware Version: I don't know the firmware no.please check the screen shot.
  3. Rooted or not: no
  4. Frequency of Occurrence: not working even for 1 second
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Mobile data is on and showing edge Mobile data or 4g Mobile data in quick settings but still unable to use it. Please check the screen shot for firmware no. It's my problem that I am missing some settings or Asus has a bug.

Data roaming is on.mobile data is on. Please help me out I just my bought my phone yesterday. If my phone is defected then I need to return it.



Comments

  • Hi @puneet,

    Try this:

    1. use a different SIM
    2. use the same SIM in different phone
    3. Check APN settings -> Mobile Network -> Data - APN, try resetting from tapping on above 3 dots
    4. Last you can backup and reset your phone once
  • Same problem, but now solved. Go mobile networks and open access point names and delete APN

  • sermed2003sermed2003 Level 1
    edited September 2020

    I have the same problem as well, but it says: "Access Point Name settings aren't available for this user". And even after I reset to default, it doesn't change anything

    Could someone please help?

    EDIT: I just searched up the APN for my network provide, and follower the steps on there. Now it works perfectly.

  • Same problem with me. I contacted asus and they firstly classed my phone as doa, I returned it to the shop and was given a replacement, and it still has the same issue. I've tried all the apn fixes for Vodafone Australia but still not working only intermittent and on wifi.

  • I have the same issue, but non way to edit the APN, i have allways the same error message.

    How did you do at the end to modify the APN ?

  • Hi, I am having the same issue, last week i purchased Rog 3 global version 12gb/512gb version and using it in Saudi Arabia on STC network. Signal works with high speed on My old mobile but Rog 3 failed my expectations, sudden disconnection of internet every time, keeps connecting and disconnecting every 5 mins i have to keep toggling Airplane mode On/Off to refresh network signals. Everytime when I have to go online I have to goto nearby WiFi to have a stable connection. Already Update to 17.0823.2008.78 but still the same problem. Already done Factory reset twice but still the same problem.


    VOLTE option is not showing in Settings>Network & Internet>Mobile Network. I checked from my service provider (STC) and they told its already active from there side. I used to to VOLTE in my old mobile. Everytime I call someone network switches from 5G/4G to H that results in bad call quality

  • Same issue for ZenFone 5. Nothing seems to help.

  • I just received the Tencent version myself and had the exact same issue. What seemed to work for me was an issue in the APN settings where it had doubled up on my proxy and port numbers. The fix for me was to go into the APN settings and change the proxy to not set and the port to not set. It was using the same numbers from the MMS proxy and MMS port when it needed to have no value. Worked straight away from there.

  • I am facing the same network issue in my asus rog 3 ...everytime after call network disappears and then i have to put airplane mode on/off to get back the network....plz. Fix this

  • Hello khawar

    Go to the network and internet settings

    Mobile network

    Access point names

    You will see three different options

    2 optiona will be duplicates

    Delete one of the aljawalnet.com.sa

    Keep one and the mms it worked for me

  • Same problem here my data nkt showing and no data all is running good i both this nov 4 ithough i dont have data but i switch in my other phone and its working please Fix this problem


  • I have the same problem I changed the sim but still the same issue everything works except the mobile network 😑

  • byonykzbyonykz Level 1
    edited November 2020

    It seems that both sims won't work in the same time. So if you wanna use the mobile data from the second sim you have to go to Settings -> Network & internet -> SIM card -> under "Preferred SIM card" go to Data service network and there you can select wich SIM you want to use mobile data from.

  • I had this issue. It was saying that I was connected to 4g but I got no internet. The way I fixed this was following the instructions of another user on here.

    I'm with Vodafone, so I had to go to their website and add the APN manually on my phone. There's a 25 step process on the Vodafone site on how to do this. Type this into google: "I can't access the internet - Vodafone Smart First" It should be the first link (cause 8 of 9).

  • Same problems in Germany. T-Mobile and Vodafone. Short solution in my case is to reset the apn - but i've to do this everytime after i disconnecting to a wifi connection.

  • Thanks! As for vodafone, this perfectly works. I had the same issues where I was shown that I go no internet but still connected to 4G. After doing all the steps, data works perfectly fine now.

  • Guys now what is the solution about this i return my rog 3 global version because of this problem this phone is verry nice and i like it but the problem is data connection now working even u reset connection its showing the 4g sign but if u open the google he said there u dont have connection or internet please fix this i dont know if this defect or what guys ...whats your idea about this or Asus compony

  • I had the same issue I fixed it with deleting some of the unused apns

  • What is the solution to this? How to enable manual APN settings?

This discussion has been closed.