Hypercharge not working

akhilj66akhilj66 Level 3
edited September 2020 in ROG Phone 2

I have 8gb/128gb Indian variant with which I got white 18w fast charger in box. Soon after I purchased black 30w Asus charger in February to hypercharge but after around 6 months later today I suddenly found that my phone isn't charging and lockscreen says - hypercharge not recognised. I tried my 18w charger that came in the box and it's working fine. Tried my 30 watt charger with a phone which supports 18w charging and 30 watt charger is working with that.

So, in my opinion hypercharge protocol has some issues. Now I don't know whether the problem is from charger or my phone.

Please help me fixing this issue. I have checked there is no problem with the adapter or cable or socket.

@Anders_ASUS @LP_ASUS

Comments

  • Normally a lack of hypercharging is directly temperature related. If the phone or battery is too hot, the phone will not fast charge.

    If the phone is not abnormally warm and the fast charge feature is not working, I recommend submitting the phone and charger to your local ASUS repair center for a warranty repair.

  • Kindly visit the nearest service center:

    Due to the lockdown, service centers may not be functional. Kindly call the service center before you visit one.

    https://www.asus.com/in/support/service-center/india

  • Thanks, I have submited my phone at the service center.

This discussion has been closed.