Wireless ADB connection is inconsistent on Zenfone 5 Android 10 Beta 3

edited September 30 in ZenFone 5 Series

Please tell us some basic information before asking for help:

  1. Model Name: ASUS_X00QD
  2. Firmware Version: QKQ1.190723.002.WW_Phone-17.0615.2005.25-20200604
  3. Rooted or not: Not rooted
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Steps to replicate:

  1. Bind your device with `adb tcpip 5555`
  2. Connect with `adb connect YOUR_IP_ADDRESS:5555`

Actual Result: `failed to connect to '192.168.0.11:5555': No route to host`

Current workaround:

Re-enable Wifi and command `adb connect` again

While cable-based ADB is working

Comments

  • Hi johncyrillcorsanes

    Thank you for your asking. Kindly provide the information below so that we could better assist you.

    1. Have you ever unlocked or rooted your device before?

    2. Could you use the wireless ADB before? Does the issue appear after any system download or update? If it did appear after system update, which version?

    3. Could your cable-based ADB always work, no matter which firmware?

  • Hi johncyrillcorsanes

    After investigation, the tech team confirms that the wireless ADB could be operated properly. Kindly check if the device is linked in the same domain. Thank you. 

This discussion has been closed.