Touch is not working after March update in Max Pro M2

2»

Comments

  • 1. The root integrity check failing was caused by the recovery not being updated to android 9 from android Oreo that is why it is saying that 92 new files was found because it did not recognise the android 9 files, the only area where it can cause issues is when updating through fota and this issue was somehow solved by asus, it cannot cause touch issue .

    2. No user have ever experienced a issue like yours, that is why the moderator said that.

    3. If it was a software issue, manually updating the device by downloading the firmware from asus website should have fixed it(but I don't know how it was fixed when you updated your device to android 10).

  • It's totally baseless. Alankar and Pulakesh to faced problems regarding touch and you go on to say this problem has only been on my phone. How many people must have got their screens replaced not knowing this problem exists.

    Oreo to Android 9 must have been updated way back as on ASUS India site, too many upgrades of android 9 are there.

    I can only say ASUS service is not upto the mark. Customer is given wrong advice or left all at sea.

  • 1. Why I said "No user have ever experienced a issue like yours, that is why the moderator said that" was because I have never seen any one post that their screen touch is not responding in the forum( since the launch of the device) and also the person who created the discussion stopped posting so that means the moderator and him have found the cause for the issue.

    2. Service center only knows about major issues (like the device being bricked by a firmware update) and only things they can do is replace hardware, reflashing The firmware and replacing the whole device.

    3. If you have any issues with the device then please post it in the forum or ask directly to the moderator @Christine_ASUS because he/she have helped a lot of people to replace the device when a software update bricked a lot of devices.

  • If you see this post, there are three people in total who are reporting the problem of touch not working. Alankar, the person who started this post, found the solution either through help from @Y_ASUS or himself that is not very much clear. Pulakesh did not find a solution and neither did I from the moderators.

    Already @Christine_ASUS was there, when you elaborated with an article on the problems which are there with Zenfones, particularly M1's after OTA upgrade. With slight variations, Alankar's, Pulakesh's and my M2 problems were similar.

    Pulakesh took it to ASUS service I also took it to ASUS service, and we were told to get the Screen replaced.

    If problems in various ways are known to occur after ASUS OTA upgrade, with these Zenfones, then why does ASUS service not do a base firmware re-flash, instead of advice on unnecessary repair?

  • Hi mukesh_mehra1

    Thank you for your reply. Kindly refer to the reply as below

    1. For an user having the knowledge of performing "Root Integrity Check", I can not guarantee your usage behavior is as same as Pulakesh or other users. You may possibly trigger some process similar to unlock or root behavior. For an usage behavior as a ordinary user, the Factory Reset and SMMI test can assist me and the repair center to diagnose the big picture of the issue.

    2. If you still need any assistance next time, as I mentioned above, I may need your logs for further checking after I confirm some essential information. Always willing to help.

  • It is not rocket science or user familiarity on "Root Integrity Check". It's given in the 'Recovery Menu' of ASUS Zenfone Max Pro M2, Android 9. One has to just select and wait for results.

    Your point 2 says for further help, you may require logs for further checking, it's not clear what kind of logs? You asked for screenshot for SMMI test result for Display, which I sent, also with Touch test, which both were positive.

    Let's be fair, ultimate reply from you would have been to take it to ASUS service.

  • Hi mukesh_mehra1

    Thank you for your reply. Nothing is rocket science here to be fair, we are not NASA :)

    To check on your issue, please assist me to downgrade your device by the following steps below

    1. Download "Version MaxProM1_downgrade_to_9" and then put the image file into the root directory of the MicroSD card.

    https://www.asus.com/supportonly/ZenFone%20Max%20Pro(M1)(ZB602KL)/HelpDesk_BIOS/

    2. Insert MicroSD card into phone and then power off the device.

    3. Long press with "Power" key and "Volume Down" key together and stop after feel the vibration to enter Recovery Mode

    4. Use "Volume Down/Up" key and press "Power" key to choose "Apply update from external storage"

    5. Select the downgrade file

    6. When the updating process is done, Choose "Wipe data/factory reset" and tap"Yes" to perform the master clear.

    7. "Wipe cache partition" > "Yes"

    8. "Reboot system now" 


    #Android 10 to Android 9 Guide 

    https://www.asus.com/support/FAQ/1042349


    After downgrade to Android 9, if the issue persists, please  do not hesitate to contact me. I will PM you with the guide of collecting logs to avoid any personal information leaking.

  • Hi,

    Its not proper to say "Not even one user reported issue of un-responsive screen" after update. I also had same issue on m2 and It started after march security patch update. Even visited service center. They checked and downgraded the android update to 8 and told me to not update to pie version for 1-2 months. After 3-4 months I updated to pie as an update notification always pops up in between any thing on daily basis, and hell ! screen again stopped working out of sudden. It's surprising that Asus is not aware about issue, while I am writing about the issue and explaining it customer service executive for last 6 months .

    And yes I tried everything-

    1. Safe mode
    2. Hard reset
    3. Downgrade
    4. Upgrade.
    5. Cache wipe

    Still problem persists, at the time of writing of this comment, my phone is ON, Charged , Recharged, Full On Network, Finger Print Unlock working, but I am not able to use it because of a fault of yours for which we paid and suffered.

  • Hi anooops

    Thank you for your reply. Kindly provide the information below so that we can better assist you.

    1. The frequency of the zero-touch

    2. Have you ever unlocked or rooted your device?

    3. What is the firmware version you facing the issue? WW-16.2017.2009.097?

    4. If you still can use the screen from time to time, can you provide me the logs in Android 9 for further checking? If you can not use the screen, please contact with the local repair center for further device checking.

  • Hi Christine,

    1. Frequency of the zero-touch was initially 2-3 hours per week thereafter it gradually increased, when device was last usable in last September zero-touch frequency increased to 8-9 hours daily.
    2. I rooted my device only after first time I got this issue in may 2020. Which didn't solved the issue.
    3. I am not able to use it so I am not aware about the firmware but I can say issue was observed only after march update.
    4. I visited service center, but as per them service would be chargeable, and they can't guarantee if the issue would be resolved or not.

    Please suggest further ways.

  • anooopsanooops Level 1
    edited November 2020

    All those users who are having same issue with the device and can be come together and report it in more elaborate manner, please message me here. We can collate all the issues together and report at appropriate place.

    Thanks!

  • Hi anooops

    Thank you for your reply. What you described indicates high possibility of faulty hardware, please bring your device to the nearest repair center.

    Besides, please note that once your device has been rooted or unlocked, it will no longer be regarded as original product. The Revised Product will no longer be covered under the warranty of the Original Product. Sorry for any inconvenience it may be caused. 

  • Hi Christine,


    Can you be more elaborate and specific on "Faulty hardware". is it device had faulty hardware when sold?

    Also I don't know what we mean by device being rooted or unlocked? If it means it was supervised by someone other than authorized service center than it is not rooted or unlocked.

  • Hi anooops

    Do you face the situation since the beginning periods? How long have you used your device? The hardware issue can be caused by various reasons from compressed (put the device in jean pocket), break, to fall. If you have any concern, please bring your device to the nearest repair center for further device checking.

    Root and Unlock are the steps frequently used by power users to flash customer rom or customer function.

  • No I experienced the problem in march after 10 months of usage.

    I have not flashed the ROM or did anything with it.

  • The touch screen problem exist for me also from September 2020. I bought the phone 2018 february.was good untill an update happened after 3 months about.firmware was updated and was fixed for a while until new firmware and updates happened and touch screen died again.there is no hardware problem since many people face same issue.i update with adb sideload to android 10.problem still exist.then downgrade to 9 as you suggest in official site.still touch screen not working.i wait stable android 10 or 11 firmware to check if problem fixed.these model has problems from beggining.

  • Guys I have the exact same problem. The touch screen works intermittently. I had gifter this phone to my mom and I worked away from home. She complained about touch not working and I thought this is probably some software issue she is not able to fix. Unfortunately when I found out this issue is not solvable even after numerous reinstall and manual upgrades. Its definitely some hardware issue. But now I have to pay for my faulty device's repair that was caused by the manufacturer's update? Asus support seems to be really ridiculous. Guys lets post on asus's twitter handle and product release tweets about this issue. I paid for it through my hard earned money and they gave me a faulty device.

  • Hi Abhishek Das

    Thank you for your asking. Please try "the Factory Reset" 

    Settings>System>Advanced>Reset options>Erase all data(factory reset)

    **the Factory Reset is completed, all data, apps, settings and personal information will be deleted.


    Are you used to put the device on your back pocket? Or have you ever dropped or broken your device before? If the issue remains the same after performing Factory Reset, please contact ASUS repair center in the country of your residence: https://www.asus.com/support/Service-Center-All-Countries/

    If it is impossible to access the service center during Covid-19 period, please try CallUs: https://www.asus.com/support/CallUs

    **Please backup before you submitted to the repair center.

Sign In or Register to comment.