Touch is not working after March update in Max Pro M2

When I boughg new Asus Zenfone Max Pro M2 phone there was touch issue.

I requested for return on flipkart but they sent technician and he just reset the phone. Again next day touch problem occurred and technician did the same again. This return and reset process continued 5 times i.e. I put the return request on flipkart 5 times but they didn't approved the return. Meanwhile I got the next Software update on my phone and phone worked till March( When the warranty period expired). But after March update the touch problem started again. It lasted for 2 days and started working automatically. But after around 10 days the same problem occurred again. This time it didn't get resolved automatically. Then I did factory reset, no benefit of this....then I downgraded to WW_Phone_16.2017.1912.072 from WW_Phone_16.2017.1912.092

But no gain...touch is still not working ...now I installed anothet version i.e. Android 10 beta version from official Asus website. Touch still not working.

I decided to downgrade it to the earlier version i.e. WW_Phone_16.2017.1912.072

But it showed error

E3304: This package is for ASUS_X01BD devices. This is X01BD device.

Now I changed the code where it check the Device Model. It is available in Updater script file. And installed the framework WW_Phone_16.2017.1912.072 using TWRP recovery. This time touch started working.

Please tell me what is the exact problem behind this touch issue.

And please fix it in new firmware update and release as soon as possible.

«1

Comments

  • Hi Alankar,

    Please check your inbox for a message I have sent you. Thank you 🙂

  • I am also facing this same problem.I am not familiar with such kind of things.Please help me.

  • edited September 8

    Hi Pulakesh

    Thank you for your asking. Kindly provide the information below so that we can better assist you.

    1. Did you just purchase the device and want to request a refund?

    2. How long have you used the device?

    3. Your current firmware version

    Settings>System>About Phone>Build Number

    If you try to update to the latest version, does the issue still persist?

    4. Does the issue appear after any system/apps' download or update?

    5. Can you elaborate more on your issue? What kind of circumstances have you faced the issue?

    6. Please try to enter "Safe Mode". If the function works well in Safe Mode yet the issue remains out of Safe Mode, please check on any disturbance from the installed 3rd party apps.

    # How to enter and exit "Safe Mode"

    https://www.asus.com/support/FAQ/1005163/

    7. Also, please try "the Factory Reset" 

    Settings>System>Advanced>Reset options>Erase all data(factory reset)

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

  • I tried every possible way( safe boot,fastboot, hard reset,soft reset etc.).

    1.its been 1.5 years of purchase.If there is any kind of refund policy,that will be helpful.

    2.currently i am using anroid 10 beta.Also Tried other updates like pie, but the problem was in also there.

    3.I am unable to search Build number,as my touch response is completely not working.

    4.I think the problem was started from pie update.

    Its my last hope.Hope they will find out a solution.

  • Hi Pulakesh

    Please avoid posting overlapping message, which will disturb the mods and the users to answer the question. As I mentioned in another thread: as far as I can recall, I haven't received any user reporting zero touch response issue after the firmware update in Max Pro M2 A10. Please bring your device to the nearest repair center for further device checking.

    https://zentalk.asus.com/en/discussion/25349/

  • My Zenfone Max Pro M2 Touch Screen stopped working all of a sudden. Had to do recovery - Wipe Data and Wipe Cache and reboot, wherein it again started working. Afterwards an automatic notification to update firmware appeared. After updation, touch again stopped working. Before this update I was not aware as to what working firmware it was. The upgraded version is ending nos 094. In recovery there is option to Root Integrity Check, where after selecting it says, system check failed. What could be the problem? Shown it at ASUS service, they say to get screen replaced and not willing to look at the software issue.

  • I am reporting zero touch response issue after update. It would be unfair to say on your not being aware as to any user reporting zero touch response issue. Alankar, Pulakesh and me are reporting the problem of unresponsive touch after update of firmware.

  • edited September 15

    Hi mukesh_mehra1

    Thank you for your asking. Kindly provide the information below so that we can better assist you.

    A. Does the issue appear right after any system/apps' download or update?

    B. Did the phone break or fall before?

    C. Try to remove the Screen Protector if your phone has one.

    D. Please try the following steps to access recovery mode for the Factory Reset:

    0. Try to back up your data with USB cable

    1. Power off the phone, then keep pressing "volume down key"

    2. Press "power key" and stop press " power key" once you feel the vibration. Still keep pressing "volume down key"

    3. Stop press "volume down key" once you enter [Android Recovery] Screen

    4. Choose "Wipe data/factory reset">"Factory data reset"

    5. "Reboot system now"

    #Hardware Reset Guide

    https://www.asus.com/support/FAQ/1006346/

    Please note that once the steps are completed, all data, apps, settings and personal information will be deleted.

    E. Please try SMMI test 

    Calculator> type ".12345+=">SMMI TEST>Single Test>Display Test

    If any of the SMMI tests fails, indicating high possibility of faulty hardware, kindly bring your device to the nearest ASUS repair center for device checking: https://www.asus.com/support/Service-Center-All-Countries/

    If it is impossible to access the service center during Covid-19 period, please try Call us: https://www.asus.com/support/CallUs

  • The phone became erratic.

    1 Went into recovery mode - wiped cache - did Wipe data/ factory reset. Phone became okay.

    2 After some time notification was there to update firmware!

    3 Updated firmware and then the touch stopped working. My recollection of this update was that it was build 094

    4 The issue appeared after update!

    5 The phone has neither fallen nor it is broken!

    6 There is no Screen protector on it.

    7 In recovery mode (Android 9), option is there to do " Root Integrity Check" did that. It said " System Check Fail"

    8 Went to ASUS India site downloaded WW-16-2017-1912-072-999-user.zip copied to SD Card and loaded in recovery. Touch did not work.

    9 In sequence uploaded WW-16-2017-2002-073-user.zip did not work, then WW-16-2017-2005-092-user.zip did not work, then WW-16-2007-094-user.zip, which again did not work.

    10 None of these updates helped and screen touch did not work. After all these updates, CACHE and DATA wipe was done, also I kept doing "Root Integrity Check" and results always were:

    Error:found 93 new files, Error: found 91 lost files, Error:found 1 modified files, Error:boot NORMAL check Fail, Error:boot Advance check Fail. System check FAIL!!

    11 Now the Position is, touch screen is not working and on mobile we have first page, that is the language select page. Took my mobile to ASUS service, they said screen is bad, as touch is not working, so replacement of screen is required. They did not at all look as to it can be a software issue! Explained to them the errors being reported in software but to no avail. I did not give it them for screen replacement, but had to tinker with it my self to get it on and running.

    As of now I am on WW-17-2018-2004-424-user.zip which is Android 10. Its recovery does not have option of Root Integrity Check. The touch is working. After receiving your message, Did SMMI Test for Display and Touch and results are "Passed".

    The path to this upgrade, to make it running was not easy, somehow it happened. If this had not worked, I would have had, had to go back to ASUS service and agree with what they would have said.

    Do you still think it could be a bad screen, and soon it would reach back to being unresponsive?

  • Hi mukesh_mehra1

    Thank you for your reply. Has the device been unlock or root before?

    To my knowledge, if the hardware is fine, the device should perform well after performing the Factory Reset because the software is flashed back to the original version without any 3rd party disturbance.

  • Nope! device was not rooted and factory reset did not work. Even getting onto Android 10 firmware was difficult. It started to respond after Andoid 10 update, touch still was erratic, with difficulty and with long waiting duration's, was able to get into developer mode, downloaded Unlock apk file from ASUS website, rooted mobile. Again wiped data and cache, re-updated Android version 10 and somehow this did the trick.

    What I was looking for from ASUS service was to look into this software problem, towards which they were adamant on changing of Display screen. I am not into gizmo's and had to browse a lot to gather knowledge as to how problem can be rectified. I love my phone and had a feeling on not getting screen replaced as then after repairs it would be half a phone left. Still I am keeping my fingers crossed.

    Is there a way to check system files? Wanted to make sure on software being okay, like I said, earlier in Android 9, I was receiving message of System check fail!!

  • edited September 16

    Hi mukesh_mehra1

    Thank you for your reply.

    1. Can your device get into SMMI test now? Please provide me the screenshot of the result.

    2. How often does the zero touch issue occur?

  • Let's go in phases to reach at conclusion on my phone issue is same as the piunikaweb.com article. As a layman what I understand of the article is that ASUS Zenfone OTA updates follow Block OTA method which update in same partition and their is no fallback. Newer versions???? of Android support payload based OTA via A/B partitioning, wherein update takes place in one partition and if it is non workable their still is old system to fall back upon. The article says ASUS Zenfone do not follow A/B partitioning method. As I am no expert/authority on these matters, would like to know your opinion, what I have understood is right?

  • You are currect, the only downside for a/b partitioning method is that it takes a lot of storage (2 to 5gb). Because of it a lot of OEM's are not implementing it in their devices (samsung have never used the a/b partitioning method). But it changes from android 11 because it does not allow any method other than a/b partitioning method for system update.

  • Hi mukesh_mehra1

    Thank you for your reply. How can you pass SMMI test while your screen can not be touched? 😅 Besides, what is the frequency of the zero touch issue?

    Please reply the question above, and I may need your logs for further checking.

  • He said that the issue was solved when he updated from android 9 to android 10 beta, and the smmi test was from the android 10 beta.

  • Oh ok, thanks veeharish2005.

    Well, I can hardly tell the root cause or the reason why "Root Integrity Check" (did mukesh_mehra1 access from the process here: https://www.asus.com/support/FAQ/1006346/?) failed in Android 9 because the device was re-flashed with Android 10 OTA file and I have not been in the same user behavior exactly as him. I can not know what the usage process while the device was in Android 9. However, please let me know once the issue appears again. I may need the logs for further checking.

  • So to conclude the thing comes up is that ASUS Zenfone update method is Block OTA. The article also says that Zenfone Max M1 owners faced problems after updates similar to mine. So this problem exits on Zenfones.

    Now the surprising part is that how come, ASUS service is not aware about it? How can they recommend to change Touch screen when it is not required so? This reflects very poor on ASUS service and casts bad shadow on a very fine product.

    On this page itself an ASUS customer Pulakesh is there looking for help, the problem is same what I faced, how are you people going to help him?

Sign In or Register to comment.