Asus UX301LA wrong BIOS

filippostucchifilippostucchi Level 1
edited September 2020 in ZenBook

Good day to everybody,

after spending days to solve some issues on Wifi card of my Zenbook UX301LA, i decided to try to update the bios.

I downloaded the latest version from asus support webpage but unfortunately i choose the BIOS for model UX301LAA instead of UX301LA.

I flashed it through Easy Flash and now my laptop is powering on but it is loading directly the BIOS.

I tried to reset all default setup, to play with some settings but nothing, i'm still not able to run windows.

Could somebody help me to solve this issue?


Thanks in advance

Comments

  • Well you're able to boot in to BIOS so just download the correct BIOS for your model and flash it again! (EZflash) Extract the BIOS ZIP file to a memory storage (USB stick or SD card) , choose the file in BIOS EZflash and voila!

    www.asus.com/uk/support/FAQ/1008859

    www.asus.com/uk/support/FAQ/1042868

  • filippostucchifilippostucchi Level 1
    edited June 2020

    Dear Junaimahmood,

    First of all thanks for your reply.

    I already tried to re-flash all versions of BIOS without success...

    Following the second troubleshooting guide you posted, I recognised that on boot options is not present any selection, so it seems that the bios is not able to find the hard disc:

    The strange think is that If i enter inside the Easy flash utility i am able to surf in all partitions and directories of the hard drive:

    I really don't know how to solve this situation... 😭


    UPDATE: I enabled the CSM option and now windows is loading fine!!! Now i have another issue... i am not anymore able to enter in the BIOS, i tried all Function keys, canc and esc but nothing...

  • Hi, you can enter BIOS via Windows, click start>power>hold shift and click restart. Then click on advanced options>Restart to change UEFI firmware settings.

    Strange that you can't enter BIOS again, maybe you're tapping the wrong key or tapping it wrong. First turn off your laptop, plug in charger, turn laptop on and straight away keep tapping (don't hold) the BIOS key (I think it's F2) until you see BIOS screen.

This discussion has been closed.