Strange WIFI problems, driver related

edited September 2020 in ZenBook

Hello, I have been have some strange wifi problems with my asus zenbook pro model UX501J (UX501VW almost identical) it has an intel duel band wireless-AC 7260 wireless card in it, for some reason as of a few days ago after trying to cast to a miracast device my wi-fi card has been acting strange at first I though it was the drivers gone bad for some reason so I reinstalled the drivers from scratch and it sorta worked but when I tried it again I notice something strange right after I uninstalled the drivers by uninstalling the device in device manager if I refresh devices all the drivers have re installed them selfs...... so I uninstalled them in safe mode and they didn't reinstall in safe mode... so I found the drivers and deleted them my self and restarted they came back almost instantly but the wifi was working fine.... so I though I had fixed it but after I turned it on the next day the wifi was all wack again.... the problem I keep haveing is after I restart the computer after it self reinstalls the wifi drivers the wifi brakes in a strange way and that is that out of the 5-8 wifi nets I normally see it now can only see 1-3 of them (there are 2 routers in my house on different channels 1 has 2.4 and 5.0 separated) and they all have very low strength from in the same room, the strange thing is is when I connect to one it suddenly gets full signal strength and the others just die out completely and if when im in my room (opposing the side of the house with the routers) if cant find any wifi networks but if i then go back into safe mode and uninstall the drivers again and reboot it can see and reconnect just fine until the computer restarts... I lost my wifi password & got it back inbetween. also all other wifi devices work fine in my room with 40 Mbs down 5 Mbs up so... any ideas?

Comments

  • HI,

    did you try switching plain-mode on/off? My UX with AC 8265 on 802.11ac network sometimes enters limited 30Mb/s speedtest speeds. Switching to plain mode for few seconds then turning it off returns to max available internet provider speed. Don't know what causes it. 30Mb/s is enough for daily tasks so I rarely notice it.

    Did you try installing drivers manually? Does driver version changes between bad and good? If not, then certainly it is not driver issue. If indeed driver version changes, then perhaps update driver from device manager selecting your own driver. Feeding Windows with right drivers usually doesn't fail until major Windows update. AC 7265 never caused problems to me on Dell laptop. Are you sure it is not AP / router fault? WiFi cards sometimes die as well.

    Didn't your WiFi channels change? It is not clear which band are you using, both 2.4 and 5GHz are bad, or just one of them. At 5GHz you may face some DFS issue, channel may change, signal power from router may drop. Did you try cycling your APs/routers on/off? If you think it's SW problem, perhaps try creating Ubuntu live USB using Rufus. Boot from USB and see how your WiFi behaves, perhaps disabling WiFi several times and checking signal levels and connectivity. It would help checking your WiFi card.


    Edward

This discussion has been closed.