USB ports stopped working suddenly Asus ROG laptop running Windows 10 - Can't locate drivers. Help!

mortimasyomortimasyo Level 1

Problem: Out of the blue last week, my wired mouse stopped working. I unplugged it from the USB port and plugged it back in, and nothing. I then noticed that my external portable USB drive was not showing up. I then checked the mouse and drive in a different computer and both worked, so I realized it was the USB ports. Upon investigation, I opened device manager and found under "universal serial bus controllers" that all three drivers had a yellow yield warning symbol (see attached screen grab) and when I opened the properties on one of them, the "device status" states:


Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

{Bad Image}

%hs is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0x


Screen shot here: https://drive.google.com/open?id=1T7PA7X2Om9CJyPFGudiXtBwyHzoAG1w3


After googling and reading suggestions, I tried to uninstall the drivers and restart the computer, only to find they came right back with the same error warning. I also tried in vain to find an updated driver (as the driver date shows 6/21/2006--over 12 years old!!!) but I couldn't find one OR Im not looking in the right place.


I did try a fresh install of windows by going through the Recover > Reset this PC option, but I get a notice that states "Could not find the recovery environment". Upon investigation, apparently I need to load something onto a USB drive and proceed that way, but that wont work specifically because the original problem has to do with sudden non functioning USB ports.

Sign In or Register to comment.