Poor SK Hynix SSD reliability

ekarpiczekarpicz Level 1
  1. System:
  2. Battery or AC: both
  3. Model: UX331UA
  4. Frequency of occurrence:
  5. Reset OS: no
  6. Screenshot or video:

========================

Detailed description:

Hello

I faced SK Hynix SSD unreadable sectors issue on two identical UX331UA Zenbooks! Windows reported model number is HFS128G39TND-N210A in both cases.

After less than 2 years usage and only 4TB written doing Macrium Reflect disk image backup process stopped with unreadable sector error. Poorest SSD’s on the market offer TBW / SSD size ratio of 200. I’m at 4TB/128 = less than 40. Perhaps the problem rose due to high disk space usage? SSD was up to 80% filled and the most of the data was not refreshed for quite long. Any problems with this?

I checked if my Zenbook is on warranty. It is until the august. But this SSD is 128GB, which is about 25Eur for new one. Should I send my PC to service and bother persuading them this “perfect” SSD has problems? Funny thing is that according to SK Hynix SSD utility, Crystal Disk Info and other software this SSD is indeed in perfect state! Let’s see.

First disk “surface” scan using Victoria:

As you may see I had uncorrectable unreadable sector at ~75GB, see speed drop to 0MB/s, as well non zero Err counter. Linear reading speed dropped many times from 300+MB/s down to 100 and even 50MB/s. Speed dropped because so many sector blocks took 2 and even 5 seconds to read. I guess it could be something like floating gates self discharge. Data wasn’t refreshed often, so perhaps it was something like that.

I had to erase lost sector to be able to make backup ASAP. I found later that Macrium Reflect has option to ignore unreadable sectors, but I was at hurry saving my data, so I erased just those unreadable sectors. Err counter became 0, Reflect had no problems doing backup. After backup was done I did several whole disk readouts with Victoria. This was increasing some RAM S.M.A.R.T. counters, but speed drops on slow sectors became less frightening. Finally I did read-write refresh on slow sectors, and it restored sequential read speed. See how it looks now:

Just perfect, slowest 16k block takes 0.03s to read. I guess those areas with ~500MB/s speed belong to erased locations and ~300+MB/s areas belong to used locations. These 500/300 jumps are quite odd for SSD, but I don’t mind them. I didn’t do whole disk read test soon after buying, would be good to know how it looked like on new Hynix SSD.

Here’s S.M.A.R.T.:


and the rest of S.M.A.R.T.:

GOOD. Oh yeah, unreadable data is “certainly GOOD”.

 

Another Zenbook suggested by me to my relatives had worse situation:

After similar fix:


I ordered new SSD. My advice to others please check your SSD model. If it's like mine then most likely you are in problems.


Edward

Comments

  • Hi Edward, thank you for providing us the tests result. We report this issue to our technical support team for further analysis. We will let you know once we have further information.

    Cheers!

  • ekarpiczekarpicz Level 1

    Hi Anthony,

    thanks for your attention. I retested both UX331UA's after a week. As I suspected, solution to refresh slow sectors is temporary. Areas of slow linear read speed slowly come back and reappear. Here's how my laptop with 4TB written looks like past the week. Please compare to the first (before refresh) and to the second (after refresh) picture from my first message.

    Regarding S.M.A.R.T.. For some very weird reasons Hynix SSD uses SMART attributes other vendors don't use and uses ones which others don't use. Since most common attributes, which are usually used to evaluate condition of HDD/SSDD are missing, the most of software's think the drive is OK. Here's the summary of what changed in the SMART in a week:

    Another UX331UA with identical SSD made similar "progress" in a week. Some areas of slow reads came back, some SMART attributes got worse. Since it had reallocated sectors, I replaced SSD with new NVMe drive. Here's results of linear read test and summary of changed in the SMART.

    My ZenBook with only 4TB written is only 1.7 years old. 2nd ZenBook with replaced SSD and only 10 TB written is only 1.5 years old. Both had broken unreadable sectors!  

    Edward

Sign In or Register to comment.