ASUS ROG PHONE 2 Wifi Problems on 5Ghz connection.

rubennatanaelrubennatanael Level 1
edited October 2020 in ROG Phone 2

Hi, I need help on this 5Ghz wifi connection issue. Download speed clocked in at around 10% from ISP speed which is 2Mbps. ISP speed is 30Mbps. Upload speed is normal. Connection on 2.4Ghz band of the same router is working well at max speed. I checked on other devices including ROG laptop on 5Ghz band they are working well at max speed. The transmission link on 5Ghz on the Rog phone 2 is only about 173Mbps top and sometimes hovering around 79Mbps. While the same connection on 2.4Ghz sitting at 300Mbps. I double checked the router and its working well with no glitch. Its only happening on the Rog phone 2. Please advise with the immediate resolution. Thank you.

Comments

  • Start off by resetting your wi-fi settings and then reboot your phone:

    Settings -> System -> Reset options -> Reset Wi-Fi, mobile & Bluetooth

    If you still feel that the speed is lackluster, download WiFiman (Ubiquiti Inc.) and make a screen recording for us to look at.

  • BadegBadeg Level 1

    Same here. I tried reset wifi mobile and bluetooth, and thhe problem still occur. I have tried checking the internet speed on my laptop and iphone, they all work correctly. On my asus rog phone 2 the download speed only at around 10% which around 10Mbps. I have 150Mbps internet package. This just happen very recently, i think around this week.

    Option that i have tried:

    1. the standard resetting internet (unplug, calling provider, etc2.)
    2. reset wifi mobile and bluetooth
    3. restarting the phone
    4. changing IP
    5. limiting other wifi user bandwidth
    6. Pray :D
  • BadegBadeg Level 1

    By the way, only on the 5G internet. if on 2.4ghz internet all works just fine.

  • BadegBadeg Level 1

    this is the screen shot on wifiman. But the one on speedtest is my desktop download speed for comparison. Please help..... :(

  • Hib@Gustav_ASUS I haven't been able to record the screen. But did the recommended reset wifi settings and all networks. The problem still exist. Still have similar result as @Badeg. I even tried to connect just the phone to the wifi and it still the same thing. All other devices working well on the 5Ghz connection. Please look into this matter. Thank you.

  • I have the same problem

    My Asus ROG 2 download speed is capped at 2Mbps when using 5ghz wifi.

    Still no solution?

  • Hi, yes still no solution. I tried a lot of different routers including Asus router. Reset everything and the problem still there. 5Ghz connection capped at 2mbps. I even upgraded my isp speeds, still no solution. My cheaper android phone have proper speed on 5Ghz. Tested all the routers and different locations still have no solution. All the tested routers also tested on my ROG laptop and its ok. I hope there will be a proper solution soon from ASUS. We've been waiting since May this year.

  • My ROG Phone 2 has no issues or speed caps with 5Ghz connection. Btw I'm on Android 9.

    Maybe the issue is device specific?

  • Yeah, it wasn't an issue at first. Then there was a push OTA update. I forgot which one was it then the issue exist. One of the moderator here advised us to update to the latest firmware. But, it didn't fix the problem.

This discussion has been closed.