TUF A15 FX506II Laptop - WiFi and ASUS Multi Antenna Service software issues

pblissettpblissett Level 1
edited October 6 in Others
  1. System: Windows 10 64bit - build 18363
  2. Battery or AC: both
  3. Model: ASUS TUF Gaming A15 FX506II-AL059T
  4. Frequency of occurrence: intermittent / varies
  5. Reset OS: not yet
  6. Screenshot or video: yes

========================

Detailed description:

Hi, I’m having a lot of WiFi issues with a new ASUS TUF Gaming A15 FX506II running windows 10 64bit.

The laptop came preloaded with a “Realtek 8822ce wireless lan 802.11ac pci-e NIC”

I will list the issues I’m experiencing below and also the actions taken so far to try and resolve (no success so far)

PROBLEMS:

- extremely slow to reconnect to stored SSID after restart. Often it will stall completely and fail to connect unless I manually disconnect from any stored SSID and reconnect OR switch WI-FI on and off from system tray (this may or may not work). Often I will have to let the laptop sit idle for up to 5-6mins and it will eventually reconnect to the internet (note windows Wi-Fi status shows a successful SSID + internet connection for all this time)

- intermittent (random) internet connection drops, where the system tray can show an active Wi-Fi + internet connection but all apps and browsers fail to connect (timing is random, every few mins or 10’s of minutes, but eventually it will happen)

- duplicate SSID Wi-Fi names appearing as an option to connect in windows available WiFi list. Where there is a “2” after appearing as a suffix to the SSID name. This one is very strange and bizarre. As an example, if my WiFi network is called “My_Home_WiFi_SSID”, it appears in the windows WiFi list as “My_Home_WiFi_SSID 2” and it will work with all apps connected to the internet. This is not an SSID my router is broadcasting!!


- Speed tests over 5ghz WiFi (with all conditions identical, same location, no other devices connected to AP, etc.) can vary massively from the max router bandwidth available of 250mbps to as low as 30mbps. In some case the 2.4ghz WiFi connection will get a faster connection then the 5ghz and several minutes later the 5ghz will return to 200mbps+

- As I understand it there are 2 radio antennas in these laptops and the ASUS software for controlling these antennas is called “Asus MultiAntenna Service”. This software is also recommended for download from ASUS support page when I filter based on my exact model. Unfortunately, the latest version of this software v204, from ASUS support page is corrupt and missing 2 files in the installation packet, resulting in errors during the installation. This is not a download issue as I’ve repeatedly downloaded this compressed file from a different laptop. The management service it tried to install still getting added to windows even with the install errors but the service will not start up when started directly from the windows service list. I’m assuming this could be at the route of the problem. See other attempts to resolve this below.



STEPS TO RESOLVE:

- There has been no recent changes to my router AP. All settings are the same and all other devices connected over 2.4 and 5ghz are working as normal with very fast and reliable internet connections.

- I tried installing the latest wireless NIC drivers from both the ASUS site and newer ones direct from Realtec. I also tried rolling back to original versions of the driver files offered by Microsoft.


- I have disabled the OS power management options at the driver config level in device manager

- As a test I tried changing the WiFi frequency and channel at the router side and removing security

- I downloaded an older version of the Asus MultiAntenna Service (v203 and v202). The missing files from the latest version (v204) are present in these install packages and there are no error messages during the install but the service continues to throw an error when I try to start it manually in the windows service manager.

The laptop is brand new.

Comments

  • edited May 5

    Hello pblissett,

    Thank you for your detail feedback.

    I have reported these issue to our technical support.

    May I have the brand and model of your router?

    Thank you.

  • pblissettpblissett Level 1

    Hi,

    My router is the cable modem provided by my broadband provider "Virgin media", the manual is here:

    Google: "virgin-media-hub-new-install-guide.pdf"

    To the best of my knowledge it is a rebranded "Compal CH7465-LG" modem.

    Some screen shots of my wireless settings from my router are below:


    Peter

  • pblissettpblissett Level 1

    To confirm, I have connected the laptop via different WiFi (2.4ghz) access point and the same issue problem persists. After 8-10mins it completely dropped the connection and then reconnect. I was only 1 meter from the AP so this is not a signal strength issue. Again, all other devices using this access point are function correctly with reliable stable WiFi and internet connections.

  • s_thanoons_thanoon Level 1

    Hello, I have the same issue with my brand new Asus TUF A15. Did yours get fixed?

  • Hello s_thanoon,

    Please kindly update BIOS to 309.

    and may you specify more about the issue your encountered and which router you are using ?

    Thank you.

  • xor11xor11 Level 1
    edited July 18

    Ok, this topic is relative. I have wifi problems too. Asus A15 506II, completely fresh windows 10 2004.

    I have bad ping over 2.4 GHz to any tplink 841 I saw (somehow they are very popular) in plug mode, and utterly bad on the battery. To be more precisely, battery gives me huge packet losses (spontaneous connection drops), spikes to 3k ping and 70-100ms on average after I unplug and wait some time. I've also installed new bios. I checked different driver options and power saving configurations (I don't want to list every thing I did, got no luck anyway). The same behavior persists with my phone's hotspot. I may test more routers in a few days but...

    The funny thing is that I faced this issue on two different FX506II notebooks (one of them was returned to the shop because of another problem [fan crackling noises]). I didn't pay more attention to this on my first fx506ii, but I remember some bad ping too.

    Blake_ASUS , just saying bios 309 didn't fix the problem


    edited: no matter which router I use (2.4GHz)

  • pblissettpblissett Level 1

    Unfortunately not. I returned the first laptop for a refund, I purchased a second from a different retailer and experienced the exact same issue. I eventually returned the second laptop for a refund also but not after wasting weeks of time and effort on both trying to resolve the issue and also a lot of frustration at the complete lack of support from ASUS.

    There is a clear design fault with this series of gaming notebooks from ASUS. The quality of the build and pre-testing of the system software is not up to scratch. I have lost all confidence in the brand and will not be buying an ASUS product again.

    ASUS technical after sakes support is one of the worst I’ve ever experienced. They ignored most of my emails and requests for assistance. The length of time for responses was in the order of weeks. When I did get a response it was very basic advice “factory reset”, “have you all the latest drivers and bios installed”.

    if you look on Amazon.co.uk (where ASUS sells these laptops directly) you can see another customer who experienced the exact same WiFi card issue with on of these laptops and posted a review stating he had to return for a refund.

    More concerning, I believe ASUS are fully aware of the manufacturing defect with this series of laptops but will not openly admit it and they will not provide a proper and efficient level of customer technical support to help customers. More concerning is that they are continuing to sell these laptops with the defect present.

    I am really glad to see other people who have experienced this same issue starting to post here. Please continue as it may help to support customers who have fallen victim to this poor quality notebook and might encourage ASUS to take responsibly.

  • Hello xor11 & pblissett,

    Thank you both for your feedback.

    I have reported them all.

  • edited July 23

    I also got the same problem, tried everything, nothing works. BIOS updated to 309, driver already up-to-date, windows 2004 and also up-to-date. The wifi connected to 5 GHz but only on 802.11n not .11ac which is limited to only 72 megabit/s. And of course, my router support 802.11ac (TP-Link AC750)


  • I am having the same issue. It's intermittent (internet disconnects every 2-10 minutes). The windows network diagnostic troubleshooter shows multiple different issues. I had the laptop for about 2 months before it got this bad.

    I did the BIOS upgrade, checked the drivers, pretty much everything else I found online as well (almost all of the things OP has tried).

    I guess the last possible solution is to return it to Costco. Thanks OP, for going through this first and posting it online so I don't have to waste as much time as you.

This discussion has been closed.