Google lens can't accessible... Any suggestions?

Whenever I try to access Google lens from camera interface, it shows Google lens not available, please sign in to your account.

If try to access Google lens app, it shows , thanks for updating. Lens will be available soon. Please try again later.

If I try to select photos or any images from Google photos app and tried lens option, it shows, something went wrong. Google lens not available.


Please suggest, whether google lens really not support or unavailable for 6Z or any other settings to fix.

Asus 6Z of WW firmware version.


PS: Google lens app not disabled, all permissions granted, of course signed into Google account (it's Android device right?)

Best Answer

Comments

  • _jis__jis_ Level 4

    I cannot confirm your issue with the latest WW_17.1810.2003.145 on my ZF6.

    Try to clear Data/Cache for Camera.

  • Try clearing storage for the "lens" app in apps & notifications -> see all xxx apps

  • Tried everything.... Even did factory reset (not for lens problem, just want to do).

    Cleared cache, storage and app preferences, all necessary settings in Google photos app, lens app and camera app.

  • Thanks for the practical solution... It's working now, after enabling Google app.

    Instead of " for me it's working since I bought the device or I don't have any problem after so many updates" , yours is a hand on solution.

  • I know you can't confirm... Because you don't have any of issues and your device works perfectly as do you

  • _jis__jis_ Level 4

    So it was the fault of the user who disabled an important system application. Do I understand that correctly?

  • How can you say user preferences as fault? And where Google app is mentioned as important. If so, there should be no option for disable. Using assistant or not using is purely my choice. For a while I just want to try out lens, I faced this problem, I am asking for suggestions. Where did you find fault in this hypocrat?

    By disabling one app, having impact on other app is unknown.

    As 'mastervishikh' knows about it, probably he also did same earlier, in his practical try out , he suggested. Now it works.

    As per your dumb statement, are you going tell people having problem with mother board issue or dead unit, as user fault to purchase 6Z?

    From many of your posts and queries and answers, I clearly understand your intention and dominant attitude, to show off you only know everything. I never liked those kind of people, instead I hate.

    And your comments, definitely not welcoming. Better dont irritate me.

  • It's your fault to judge other people, what they want or don't?

    I clearly knows your intention of this comment. You cannot tolerate something you don't know , other can provide.

    And moreover, is anywhere mentioned Google app is very important. It's purely a user choice to choose what to use or don't.

    FYI, earlier I used Nokia 8, in that mobile also I disabled Google app and used lens app without any problem.

  • _jis__jis_ Level 4

    I clearly knows your intention of this comment. You cannot tolerate something you don't know , other can provide.

    No, it's your fault to falsely judge other people. Please, don't be evil. I will ignore it anyway.

    How can anyone advise you to enable a system application when you claim to have done a factory reset? That wouldn't make sense. In order to get that advice, someone must have overlooked your claim that you already reset your phone...

    Tried everything.... Even did factory reset

    I appreciate that you had the courage to write down how you fixed it, which is very positive, but you refuse to accept it as your mistake.

    Ok, peace :)

  • CH_ASUSCH_ASUS mod
    edited May 28

    While unexpected behavior from your devices surely are annoying - please keep a friendly tone to eachother.


    For this particular issue, thank you @mastervishikh for your assistance.


    In a default state - if you have never signed up for Google Lens terms of service, upon first start our Camera app will notice you to sign in to your Google account. What it perhaps could spend a few extra rows is to add in 'Lens' (as that may or may not be immediately obvious).

    Upon entering the Lens app for the first time, there is a Google popup asking for approving the terms of service - after which pressing OK, 'Google' will ask for permissions to access camera - as it should.

    It is likely, at some point, in this step or manually prior to this, where you have denied Google access to your camera.

    The prompts on why Google Lens cannot access the camera, is entirely up to Google, Lens is not an Asus app and we cannot change its behavior.


    In the end, at least the problem has been remedied. The root cause is not a bug but rather a manual system permission rejection made. Thread closed.


    Thank you!

This discussion has been closed.