Zenfone 5z(ZS620KL) | Touch screen not working without any physical damage

psaswatapsaswata Level 1
edited September 2020 in ZenFone 5 Series
  1. Model Name: Asus Zenfone 5z(ZS620KL) 8GB RAM, 256 GB ROM
  2. Firmware Version: Ww_user_100.10.107.70
  3. Rooted or not: Not rooted
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app): None

I have been an Asus Zenfone 5z for a little more than a year now. The phone has been misbehaving since yesterday night.

The touch functionality was not working when I woke up in the morning, [without any physical damage (no liquid damage, no drops, no knocks) ]. However after tinkering with it and rebooting it a few times, it started working.

The problem re occurred briefly in the evening yesterday, but then it started working again without much effort.

Today, evening the problem reoccurred again without any alarm and my phone is stuck ever since. I tried restarting the phone in recovery mode but it is not working.

I am from India and with the lock-down in place, I don't know how to go about this issue. I work with a consulting firm and have to take/multiple calls through the day. Can someone please help ? I am absolutely out of wits.



  • BrunoF20BrunoF20 Level 3
    edited April 2020

    Try wipe data/factory reset (losing all no backup'd data) by

    turning the phone off,

    holding "volume down" while pressing "power button" until the device vibrates.

    Then use the "volume buttons" to reach "wipe data/factory reset",

    confirm with "power button",

    then reach "yes",

    confirm with "power button".

    When the process is done, reach "reboot system now" and confirm with the "power button" again.

    ...but it can be thermal damage by charging failure.

  • Is there a way that I can take back up of the data in my phone ?

  • sidarya31sidarya31 Level 3
    edited April 2020

    Connect mouse 🖱 through OTG cable n backup all ur data.

  • Connect mouse 🖱 through OTG cable n backup all ur data.

    edited April 2020

    Hi did any of the things worked mentioned above?

    Taking a backup is only possible if you can get the MTP working on the phone.

  • Hey,

    Thankfully the problem got sorted .

    Here are the things I did :

    Sort of the way, Jerryrigeverything checks durability test, did the same (it was anyway a piece of brick having tried restarting it almost 50 times ) and just tried restarting it one last time and Bang ! the touchscreen started working !!

    I then took a backup and tried contacting a few other people through social cycles and it seems there are a few people who have faced such issues with Asus phones (1 Asus Zenfone 5z and 2 Max pro).

    I am yet to understand why this problem came up in the first place and I would be absolutely willing to know why it happened in the first place. @ARP_ASUS anything you would suggest ?



  • rangapur.jaganrangapur.jagan Level 2
    edited August 2020

    Updated to the latest version Last week. (107.92)

    I faced this issue today twice..

    Tapping on back side of mobile has fixed the issue.

    Weird issues with this Asus mobile.

This discussion has been closed.