Asus Zenfone Max Pro M2 stuck on asus logo suddenly

18911131418

Comments

  • Actually pressing all 3 buttons make the phone switched off. But How long it will take for switching it on again. Not working for me.. anyone in this group..pls let me know

  • KubaKuba Level 1

    Well mine switch on in a while after shut down, if it shut downs try then again 3 buttons at the same time

  • Not working bro... Better u can put a youtube video. It will help lot of people

  • If you clamp 3 buttons at the same time, it really enlivens the phone. But I would like to understand what exactly is the problem. Is the firmware to blame or is the problem in the power button itself? If you replace the button module, will the problem disappear?

  • I also don't know. Because after update phone was working well for 4 days. One particular my phone charge was below 5%, so kept for charging after 2hrs it got stuck in asus logo. Does anyone phone was also in charging state... Pls let me know

  • KubaKuba Level 1

    Actually I think the problem is with the software with power button because if you click it it shutdowns. Mine phone actually shutdown for the first time when I was trying to make a screenshot and bam.

    I don't know how to simplify this instruction more but when you see that android logo ASAP click these three buttons at the same time, or try to get first up, then fast down, then fast power its really hard to recognize which method is it but click them only once, not more, if you did it well the phone will shutdown and then after a while it will switch on. Please if anyone has used the method I mentioned and shared here, if you did an update/downgrade and the phone works well please write it. It will be helpful.

  • just tweet as much as possible tagging ASUS they will surely look into this matter

  • i was using my asus zenfone max m2 as always,then suddenly it switched off and when i tried to turn it on from then its not moving from the asus logo screen, do something


  • Tweet this to asus india in twitter. Literally everyone is facing the same issue.

  • Can you please make a video on this. I tried but couldn't get the phone to boot up.

  • Today Asus technical manager called me. They are telling as of now, they didn't approve any swapping of handset in service centers. He told those who are even with warranty, only motherboard can be changed. They are also telling, they didn't recieve any complaint regarding this issue. So pls all of u mail to asus team.

  • DheemanKrSinhaDheemanKrSinha Level 1
    edited June 2020

    I have mailed them too. No point in explaining our problems in details they wont even read it properly.. This stupid tech executive gives half arsed rudimentary replies.. Absolutely horrendous customer service experience ever.. I just said atleast let me know the reason behind the sudden motherboard failure just by using an app called whatsapp. They will not answer that question at all! I strongly discourage anyone seeking to purchase new zenfone products. They dont even last a year and get bricked through software updates lmao


  • KubaKuba Level 1

    I'm sorry but I actually updated my system and this bug expanded a bit that even it didn't worked properly. But now apparently it's working fine, don't know if power bytton works and don't wanna try. I would do a video but I just can't.

    Here's the simplest instruction I can write for you:

    1. Charge your phone ( It just needs to work, maybe at least 30%)

    2. Now I know that there are some type of this bugs soo

    2a) If your phone is blank (dont show anything, no android/ASUS logo)

    -> click all three buttons in the same time and hold them for like 1 sec

    -> then the phone should switch on perfectly - if it's just turn it on but the logos are showing check 2b

    2b) if phone try to switch on but only android logo, and then ASUS are showing

    -> at the time when you see android logo shows as fast as you can hold all three buttons for like 1 sec (if phone turns blank it will switch on by itself after a few secs - if not, just after maybe half minute hold all buttons again so then it will work)

    Actually I have faced only these problems, if you have that ASUS logo is still showing with no android logo i don't know if it will work but maybe try holding all the buttons for few secs.

  • Most of the affected handsets are out of warranty. they have covered all of them under extended warranty. You should understand that this phone displayed as out of stock since long.

  • So you are saying that phone will start working if we follow these steps.

    So why does Asus says that we need to replace Motherboard for that?🤔

    Are they blatantly looting their customers??😤🤦🏻‍♂️

  • well i was using my asus zenfone max pro m2 as always,then suddenly it swiched off and when i tried to turn it on from then its not moving from the asus logo screen

    for troubleshooting i tried to wipe catche partition but the recovery mode is not working , whenever i try power button along with volume down button, still phone shutting down and again its stuck on the asus logo screen

    kindly fix this issue asap cause its so annoying and i am not able to use my phone completely beacause of it

  • surensuren Level 1
    edited June 2020

    Guys today I got this issue resolved at ASUS authorized service center, they have cleared this issue within a day

    Kindly contact any nearby Authorized service center and sort it out

  • DuskyyDuskyy Level 1

    Was your device in warranty or out of warranty ,And did u pay any money to repair the issue

  • surensuren Level 1

    Warranty expiry date of mine is June 2nd 2020 but they haven't charged to clear this issue

This discussion has been closed.