[Bug] Asus Zenbook Pro Duo Intel SST Driver not working (reinstall)

System: Windows 10
Battery or AC: AC
Description: Asus Zenbook Pro Duo Intel SST Driver not working (reinstall)
Model: Asus Zenbook Pro Duo
Frequency of Occurrence: Always
Reset OS: Yes
Screenshot: https://us.v-cdn.net/6031231/uploads/ww_attachments/202002/28/143056b5zql56o336zvq7z.png

Hi,


Again, doing some QA for Asus. Laptop was freshly reset and I can't get Intel iSST to work as it should. I grabbed the latest version from the website of Asus : Version V10.23.0.2672 from 2019/08/29. The installation works fine however the device manager shows an error in regards to Intel Smart Sound Technology OED (see screenshot). My Realtek drivers are up-to-date from the same website (Version V6.0.8821.1). Because of this bug the laptop doesn't have working sound. My only alternative is to remove the Intel Smart Sound stuff altogether.

A quick Google shows something similar (sure it's for a NUC but look awfully similar) :
https://www.intel.com/content/www/us/en/support/articles/000025131/intel-nuc/intel-nuc-kits.html

Same error code. Could it be because the Intel iSST driver from the Asus website is old, and Realtek driver was updated but not this one? Any idea?

Thanks.

Comments

  • Though failed to load external libraries sounds awfully like a driver packaging issue.
  • Hello darktears31,
    May I know if your BIOS is version 305?
    and you reset OS with the original one from factory,right?
    Thank you.
  • BIOS version 305. It was reset to vanilla windows then I've added the drivers per Asus website.
  • LiviuLiviu Level 1
    Same issue here.
    What I did was to uninstall the driver completely, restart, scan for hardware changes, install it automatically, reinstall sound driver, restart, scan for hardware changes, it will find a newer version, restart and that's it.

    Now I have the version in the picture.

    Attachment not found.
    ISST.png 533.4K
  • liviu.daniel posted on 2020/3/20 03:28
    Same issue here.
    What I did was to uninstall the driver completely, restart, scan for hardware chang ...

    That didn't work for me.

    I uninstalled everything, including Realtek Drivers. I even went and cleaned the driver store with all the stuff installed part of the package. Restarted and scan for hardware changes. Intel Smart Sound Technology SST OED and Audio Controller were not found. This is expected because the drivers do not seem to be distributed part of Windows. The fact that yours got added with an old version strongly suggest you had an old version lying around in your driver store.

    So yes reinstalling from scratch with the current BIOS and available drivers from Asus website is not possible.

    I used this to clean up my driver store : https://github.com/lostindark/DriverStoreExplorer. Super useful.
  • the latest Intel Smart Sound Technology SST OED and Audio Controller drivers can also be found from this Microsoft Update Catalog site (Intel media 2020 ms catalog search)
  • Thanks noel_prg_la1979.

    I've picked: 10.23.3406.200 and it solved the problem for me. Asus should update their driver page, clearly the version posted doesn't work with either the new BIOS or newer Windows.

  • LiviuLiviu Level 1

    How did you installed it? I tried as well, but the extension is .cab.

  • Quite simple. Extract the .cab (with winzip or similar) in a directory. You'll notice that it's the same layout as if you're extracting the zip file from Asus website. So, I just grabbed the zip files from the Asus website, then extracted it and picked the pnputil.exe file with the Instal.cmd file and dropped it in the extracted .cab directory from Windows website. Then I ran Install.cmd :) (as if I were installing the Asus one).

    Install.cmd is a generic script from Asus that invoke pnputil.exe and install any INF file in the same directory.

Sign In or Register to comment.