Asus Optimization Startup Tool + AsusHotkeyExec Windows alert at every reboot

2»

Comments

  • I have the same problem. Will try the solution from Blake_ASUS above.

  • Uninstalled the driver for "ASUS System Control Interface V2"

    Rebooted machine

    Unzipped the "AsusSystemControlInterfaceV2_2.2.20.0"

    Started Powershell as Administrator

    Executed Install.bat

    Rebooted machine

    Problem persists - still getting the popups for "Asus optimization startup task" and "AsusHotkeyExec"

    What next?

  • OK, missed the important part about not using the Windows built-in extract tool. Tried same procedure but unzipping with Win-RAR. Now it works as intended and the pop-ups are history.

  • Asus vivo book charging related query.

    Can I continue to charge the laptop irrespective of its battery status??

    Can I keep charging even when the battery is full charged %??

  • AneirinAneirin Level 1

    *** without uninstalling ***

    I followed this path and located the 2 problem processes.

    for each process: properties/compatibility/change settings for all users/run this program as administrator

  • None of the above working for me:

    Unzipped using WinRAR, installed with elevated powershell with install.bat

    Received prompt when logging in.

    Changed Settings for all users for the two processes listed to Run As Administrator.

    Reboot, no prompt. Also no working Asus key to enable/disable screenpad, open Asus software, swap apps on both screens, etc. All Asus Keys not working.

    Removed requirement to run as admin on both exes and rebooted. Prompts are back, keys work again.

    Anyone with a working solution?

  • How do you perform a full uninstall of the Asus software? I'd like to start clean and try it again. I changed the .bet file to -u instead of -i, not sure that did anything. Also, my above comment is still valid, either I get prompts and working keys, or no prompts and no working keys.

  • The guide worked for me, but let me share some more details on how I exactly did it:

    1.      Uninstall the driver for "ASUS System Control Interface V2"

    a.      Open Device Manager by clicking on start and typing “Device Manager” on search bar

    b.      On Device Manager, expand “System Devices” and right click on ASUS System Control Interface V2

    c.      Click “Uninstall device”. You will see a pop-up that says “Warning: You are about to uninstall this device from your system.”, and below that message is a checkbox that says “Delete the driver software from this device.”. Go ahead and tick on that box and click UNINSTALL.

    d.      Do a reboot/restart.


    2.     Do a fresh install of the "ASUS System Control Interface V2":

    a.     Open your MyASUS app, and click on “New Updates” or go to Software Update tab accessible thru the left side of the MyASUS App.

    b.     You will then see two tabs on the right side: Live update and “Driver & Tools”. Click “Driver & Tools”, then scroll down to “Others” category and you will find ASUS System Control Interface V2 under this category. Click on the topmost one as this should be the latest version.

    c.      While waiting for this to download, go to win-rar.com to download the appropriate WINRAR version for you. Install this first before installing the new "ASUS System Control Interface V2".

    d.       After downloading "ASUS System ControlInterface V2", open file location, and right click on the file and click “Open with WINRAR”.

    e.      Click “Extract to” on the top menu icons, and extract the file to wherever you please.

    f.       Open the extracted folder, and right click on “Install.bat” and click “Run as administrator”.

    g.      It will open a command prompt window and it might take a while, but just be patient

    until it closes by itself.

    h.      Reboot once, and if you wish, reboot again (I had to reboot twice as I seem to have

    encountered a glitch with the hotkeys, but was fixed on my second reboot)


    Hope this helps!

  • I had the same problem after updating the ASUS System Control Interface V2 driver from v2.2.20.0 to v2.2.20.10. 

    I was going to follow khutzang's instructions but when I opened the properties of the ASUS System Control Interface V2, I noticed the "Roll Back Driver" button under Driver tab. So, I clicked the button and the driver was rolled back from v2.2.20.10 to v2.2.20.0 in a few seconds.

    After that I rebooted the system several times to see if I still get the popups. Nope, now the popups do not show up!

    While this may not be a fundamental fix, but this is one quick fix to get rid of the issue.

This discussion has been closed.