Asus Optimization Startup Tool + AsusHotkeyExec Windows alert at every reboot

edited September 2020 in VivoBook
System: Windows 10
Battery or AC: AC
Description: Asus Optimization Startup Tool & AsusHotkeyExec.exe Windows alert at every boot-up
Model: X571
Frequency of Occurrence: Always
Reset OS: Yes

Hi there,

after every reboot of Windows I am getting 2 alerts about programs making changes to my computer:

#1: ASUS Optimization Startup Task
#2: AsusHotkeyExec.exe

It seems that it does not even matter if I click yes or no, the system and the hotkeys are working fine either way. But how do I get rid of those two alerts every time?

Using Windows 10 Pro, fresh clean install with all updates and latest drivers from


  • disable the notificatios for that program.
    or allow the those applications in controlled folder access
  • I have the same problem. the windows option applications in controlled folder access is not activated. What else can you do? Confirming before executing does nothing.
  • Dear both,
    May I have some screenshots of this issue?
    Thank you very much.
  • RAJU2529 posted on 2020/1/25 14:55
    disable the notificatios for that program.
    or allow the those applications in controlled folder acc ...

    How can I disable notifications? However I don't think it will help because the system alert will show at the moment those 2 programs are auto-started shortly after booting. That kind of alert which blocks the whole screen, not just a system notification.

    The task manager does show 2 autostart programs by Asus:

    1. "ASUS Keyboard Hotkeys Program"
    2. "MyASUS"

    However, there is no difference whether those are enabled or disabled! Two Windows software alerts will prompt a while after booting and the hotkeys are always working.
    Also, those entries in autostart don't have a path so I can not see which files they are opening.

    @blake_ASUS I will try to make screenshots next time I reboot.
  • Last edited by lee_LNTW on 2020/1/31 16:46

    I have exactly the same problem. Brand new laptop. Having problems with screen pad plus installing its drivers after each reboot. Reinstalled the OS as suggested by support and now have this issue too!
  • Ive found a solution to sort the pop up.
    Open the Task Manager on your PC, then hit the Processes tab and look for the Asus Optimisation process within the list.
    Right click on the Asus Optimisation process and select Properties
    Hit the General tab and go to the Compatibility tab.
    Simply select Change Settings for All Users
    Then right of the bottom of that box, select Run this program as an administrator.

    Boom, next boot, the laptop stops asking for permission and automatically runs the file.
  • Ok i tried what you suggest but unfortunately for my G14 it disables a bunch of my hotkeys. I contacted support and they gave me a bs answer to uninstall it and reinstall but the driver is not listed under their driver page

  • Hello jasonleebell,

    Have you download and install anything from our website or MyASUS recently?

  • Yes I have. I have my Asus and I did a full driver refresh from asus's driver page

  • Hello jasonleebell,

    Please kindly use 7-zip or WinRAR to extract the file then install them again.

    We found that if you use built-in extract tool, this issue would occur,.

    We are working on long term solution now.

    Thank you.

  • NevinNevin Level 1

    I also have this problem how can I fix it

  • Do I need to uninstall the drivers beforehand? and do I need to do this with all the drivers?

  • I uninstalled using Windows device manager and then reinstalled the drivers. It didn't change anything?

  • Hello @jasonleeabell ,

    After you uninstalled the driver, did you reboot ? and the pop up notice still there?

    Then you need to use 7-Zip or WinRAR to extract the file, run Install.bat by powershell then reboot again.

    May you help to double confirm this process?

    Thank you.

  • I tried this but now the hotkeys are not working. How to undo this setting. Can't find Asus Optimization startup tool in the task manager now.

    Model- ROG Strix G (G531GT)

  • @jasonleeabell How did you fix the issue with the hotkeys after this?

  • go to file explorer and follow this pathway

    This PC-->Drive C-->Windows-->system 32-->Driver store-->FileRepository-->asussci2.infamd64 (something like that, if there is multiple check them all)-->ASUSOptimization--> and then you should be able to see all the executables and then do the same thing but uncheck the administrator button

  • after uninstall and re install using this method now it work as intended thanks a lot

  • Joe999Joe999 Level 1

    I uninstalled using Windows device manager and let it delete the drivers

    then unpacked with TotalCommander,

    re installed with Poweshell Administrator worked for me!!

    Treiber mittels Gerätemanager deinstalliert (unter Reiter Systemgeräte \ ASUS System Control Interface) und den Haken bei Treiber löschen gesetzt.

    Mit Total Commander entpackt.

    Via Powershell mit Administratorfreigabe installiert.

    Problem gelöst

  • anshg2003anshg2003 Level 1
    edited June 2020

    Hey I cannot see the exact driver to uninstall and install in the windows device manager, can you please tell me where to find it?

    Edit: found it AsusSytemControllerV2

This discussion has been closed.