Getting a prompt for Asus update but it won't start

edited September 2020 in Others
Description: ASUS TUF GAMING
Battery or AC: AC
System: Windows 10
Frequency of Occurrence: Sometimes
Model: FX505D
Reset OS: Yes

I just recently purchased the laptop about a month ago, and everything seems to be going great with it, but every so often I get the popup that says an Asus update has been detected and that I should save and close any running apps or postpone it for a few hours later. I've said several times for it update right then and there, but it never does. It just pops up again usually about an hour later or so asking if I want to update. I tried updating directly from the MyASUS app, but it won't locate an update. Something I've done recently is register my device within MyASUS and I haven't has the popup since then about 30 minutes ago, so I'm not sure if that fixed it or not. If anyone has seen this or has any ideas of how I can fix it, I'd appreciate it.

Comments

  • Hello nowell1998,
    Is it an My ASUS update notice that popup at the lower right corner?
    May you able to provide a screenshot if it happened again?
    Thank you so much.
This discussion has been closed.