SIM cards not getting activated

ZT-187d9128ZT-187d9128 Level 1
edited September 2020 in ZenFone 5 Series
Model: ZE620KL
RAM: 8G
Firmware/APP Version: Android 9
Frequency of Occurrence: First time
Rooted: No
APP Name:

I restarted my Asus Zenfone 5Z while it is under charging. After restarting, both my SIM cards are not showing network. It is asking for SIM password and accepting them. But no network after that. When I try to dial a number, it says Turn off Airplane mode where airplane mode is in off condition. When I put the same SIM cards in another mobile phone then they are able to catch network. Tryied all the options..but no luck.

Comments

  • Hi vicky.variki,

    We would suggest that you try:

    (1.) Settings > Network & internet > SIM card> Disable and enable the SIM card
    (2.) Settings> Network & internet > Mobile network > Preferred network type> choose "2G/3G/4G" again.
    (3.) Power off your phone > reinsert sim card > turn on the phone
    (4.) Turn on airplane mode > wait for 3 seconds > then turn it off.
    (5.) Try using another sim card by a different operator
    (6.) Try resetting the network settings: Settings > System > Reset options > Reset WiFi, mobile & Bluetooth)

    If this problem still appears, what we would advise is that you have the unit sent in for an assessment and servicing where necessary.
    Sorry for any inconvenience this may cause.
    The link below will help in finding your local service center: https://www.asus.com/support/Service-Center-All-Countries/

    Please check your PM for a message I have sent you.
    Thank you :)
  • I have been facing this issue from last 2 months and have been calling, Mailing, Tweeting Asus but its of no use. Never expected such a poor service from a Flagship phone company. My 8 years Xiaomi phone which I am using as a Backup is working perfectly fine.
  • sidd911 posted on 2019/12/4 00:22
    I have been facing this issue from last 2 months and have been calling, Mailing, Tweeting Asus but i ...

    Hi sidd911,

    Please check your PM for a message I have sent you.
    Thank you :)
This discussion has been closed.