Proximity sensor workaround

Model: ZE550KL
RAM: 3G
Firmware/APP Version: Latest
Frequency of Occurrence: Always
Rooted: No
APP Name: Proximity

Last edited by yudh058 on 2019/8/21 03:47

"First of all, a disclaimer, im not a completely blind to this, i already doing some testing, doing some research by browsing, etc. I found some that ask for this specific question, even in this forum. But i cant find the answer until this moment. The responds always : go to service center, disable proximity in asus call screen, do smmi test, etc."

My proximity sensor is not working. It is not a software related, there is some dust inside that blocks the sensor to work properly.

My issue is, when i doing a call, proximity sensor kicked in (that's normal), but due to dust blocking it, i can not turn the screen on (to end the call, access dial pad, minimize the call, etc).
For this problem i found that proximity sensor can be disabled for asus default calling app, asus calling screen. Which of course helps a lot.

But i also using phone call from another app (like whatsapp and line) as frequently as i use regular phone call.
The problem is, disabling proximty in asus calling screen doesnt affect promity sensor usage in these apps (obviously asus calling screen is an app on its own, and that setting only set that app behaviour)

my question is :
1. Is there a way to disable proximity sensor in specific apps?
2. Or is there a way to completely disable proximity sensor universally (that affect all apps)?

I did found some walkthrough to conpletely disable it on relative older android version under privacy setting, but in android 8.0.0 sadly android setting doesnt 'facilitate' this.

Thanks
Sign In or Register to comment.