Ghost touch problm in asus 5z

Model: ZS621KL
RAM: 6G
Firmware/APP Version: 9.0
Frequency of Occurrence: 45%
Rooted: No
APP Name:

I m also facing ghost touches in my asus zenfone 5z...i can't even type properly...its working by itself sometimes....and sometimes even if i don't touch the screen it automatically working by its own....but when i face this issue i just lock the phone for a moment and then start using it....then everything works normal for a little while then againn its starts disturbing....i think it is a software issue and can be solved by new update...please look at this problem.thanks

Comments

  • Hello jackfacebook.lee,
    Please kindly double confirm if you have update firmware to V90.11.162.88
    And does this problem occur at any time, no specific situation?
    Please help to enter safe mode and switch to flight mode to see if the problem persist
    https://www.asus.com/support/FAQ/1005163/

    Thank you so much for messaging us.
    Have a nice day.
  • Hi blake asus

    I am using ZenFone selfie , last 15 days i have been facing this issue of ghost touch, i performed SMMI test which went fine, showed it to a service center they replaced the touch, flashed it , updated with latest available update, but still the problem persists, can you help with the authentic flash file, would like to try it once again

    Thanks

  • And one more thing presently i am using the same phone in safe mode but am not facing any issue, that means it is software related, that is why I am asking for the authentic flash file


    Pls help

    Thanks

  • TheseMoodTheseMood Level 2

    No, if there is no problem in safe mode, it is not a software problem. The 3rd party application you installed is the error caused by the file. You can delete recently installed apps to fix them if they are not resolved. It will be solved.

  • Hi, I have not installed any new app, moreover I performed a factory reset also still the problem persists, any other solution available pls let me know

This discussion has been closed.