Downgrade problem

ZF Model: ZC520KL
RAM: 3G
Firmware/APP Version: android 9
Frequency of Occurrence: always
Rooted: No
APP Name:

After downngrade from Android 9 BETA firmware to Android 8.1, the phone asks me for password. I have tried all variants of my passwords PIN codes etc., but without success and finaly I made hard reset. What kind of pasword I must enter?
And most important question is: When will ASUS stop mocking with its users?

Comments

  • Out of curiosity did you have a password setup before you downgraded? If so they should put it in the directions to remove all passcodes first before downgrading as an older version of Android simply can't properly read the passcode database from a newer version of Android, so it'll error out like that even if it's the right version.

    Personally I like the beta, it's working great, and for once for us to get AOSP it's a dream come true.
  • Password of what - apps, google account, screen lock?

    I bought the ASUS phone just because of ZenUI and it's features, although the most useful of them, such as ASUS Backup, are no longer available. That's why I think this AOSP update is a blur of customers' eyes - we've promised you Android 9, here you get it. If someone needs speed and simplicity, will be satisfied. But I don't need more speed, I need more functionality. And that's why I feel cheated.
  • Last edited by maceach.b on 2019/7/29 10:59

    The password for the screen lock is also the password of the OS (when you setup the password it asks if you want to password lock the boot sequence as well, so this won't work in a downgrade and will require a factory reset, that's to be expected in any downgrade when databases change).

    Sure, you don't get ZenUI, but if we are going to be honest, was it ever really reliable for us? A lot of us had nothing but issues. Sure you may not have had a problem, but the software was buggy. Going AOSP allows a fresh Android experience, and on top of that, ASUS DID warn you if you rely on ZenUI features, do not upgrade. (I'm surprised people still did it and complain later as if they didn't heed the warnings all over the download link).

    As an Android dev, I find the AOSP beta frankly more reliable than the ZenUI ROM. Less issues, less bloatware, but if you like that, that's fine. I for one welcome the pure Android experience, because now I can use other free solutions including Google's own backup solutions. They all work now, and the phone dialer, might I add, being a PHONE, is WAY better than Zen UI's. I now got spam block and a working caller ID lookup, which Zen UI simply never offered. So yea, as a dev who understands that this is a phone, I'd like my phone working better *as* a phone.
  • Hi vdishev

    Sorry for any inconvenience this may cause.
    Do you complete the downgrade process?
    Is there any error message pop on when you enter password
    If yes, please kindly show me your screenshot.
    Could you describe more clearly about the situation that it ask for password.
    Thank you
  • Last edited by vdishev on 2019/8/1 19:50
    Selena_ASUS posted on 2019/8/1 05:28
    Hi vdishev

    Sorry for any inconvenience this may cause.
    When downgrade process is completed and the phone restarts (without wiping data/settings), he shows me black screen and asks me entering password. My screen unlocks with PIN code and fingerprint. I've tried PIN - "wrong password" message. I have tried my Google account password - same message. So I ask - what password should I enter?
    The problem solves with entering recovery mode and wiping data (hard reset), which I think is generally needed when updating/downgrading from one version of android to another, but I am curious what kind of password is required
  • I've explained that to you. Password databases change, and upgrades allow for a seamless migration. Downgrading however does not. You should ALWAYS wipe when downgrading. That is just how things work. You only have forward migration, not backwards migration. Even if you had no password set up on your phone, the database is still there because it's encrypted, therefore it simply cannot be read.
  • Hi,

    Can someone guide me the steps & process to downgrade android 9 to android 8.1 for Asus ZC520kl.

  • VelvanVelvan Level 1

    If it asks password,then simply go to recovery,wipe data,cache, that's all, your problem will be solved

Sign In or Register to comment.