Fingerprint sensor not working

edited September 2020 in ZenFone 5 Series
Model: ZE620KL
RAM: 6G
Firmware/APP Version: V1.04.07.13
Frequency of Occurrence: Constant
Rooted: No
APP Name: Fingerprint sensor
Screenshot: https://us.v-cdn.net/6031231/uploads/ww_attachments/201907/07/060015eg3ysplelc222rlg.jpg

My fingerprint sensor is not sensing any contact at all. I removed old fingerprint and tried to add again but the sensor doesn't register any touch. It's like the sensor isn't even there. There's no vibration when I touch the sensor and if I hold my finger it says it's timed out. I tried restarting, cleaning, looking for updates, etc. Nothing has worked short of me factory resetting which I don't want to try just yet. Is there an update coming out? Are others having the same problem?

This is the third time I've had issues with the fingerprint sensor. The first 2 times I just removed the old scans and rescanned but this time the sensor isn't picking anything up. The first time was just about a week after I got the phone and the second was about 2 months in. I've had the phone for maybe 6 months now.

Please help.

Comments

  • Hello kirk.emamali,

    Good day.
    Is your firmware currently on the latest version WW-90.11.162.72?
    (settings> system > about phone > software information > build number)

    If yes. Please help me run the SMMI test to verify if the hardware can function normally.
    For instructions please refer to the link below:
    http://www.asus.com/zentalk/forum.php?mod=viewthread&tid=54669&highlight=SMMI

    Thank you.
  • RedlithRedlith Level 1
    I have this problem too. At latest firmware Fingerprint sensor seem to be less responsive. Back in early firmware,162.58 fingerprint function does well.
This discussion has been closed.