Unable to update firmware version

edited September 30 in ZenFone Max Series
Screenshot: https://us.v-cdn.net/6031231/uploads/ww_attachments/201906/10/104312yv0hwp0vpzcuvq0u.png
APP Name:
Rooted: No
Frequency of Occurrence: first time
Firmware/APP Version: WW-14.2016.1805.374
RAM: 2G
ZF Model: ZC520KL

I used to always automatically check for updates, but everytime i do it doesnt find any new update. It only changes the time i last checked for an update. I used to think that updates are rare, so i didnt care much.

That was until my friend told me to try manually update my firmware version. I checked the official site for updates, and apparently the current version i have is almost 1 year old (06/11/18) and there have been several updates.

I tried downloading the latest update, but it didnt work and it showed an error (see attached screenshot). After that, I thought the solution was to download each update after my current version. I downloaded the version after the version i currently have, and yet it still showed the same error. What am i doing wrong?

Comments

This discussion has been closed.