WiFi calling

edited September 30 in ROG Phone
Model: ZS600KL
RAM: 8G
Firmware/APP Version: 1903.890
Frequency of Occurrence: All of the time
Rooted: No
APP Name:

Okay so I know that the Asus rog phone does not have Wi-Fi calling, but when I am connected to Wi-Fi I cannot receive any phone calls. Everyone tells me it goes right to voicemail everytime. I have to physically turn off my Wi-Fi in order to receive phone calls. I have no issues receiving text messages and it's probably because a text message will go out of its way to wait for proper service and then send but as for phone calls it instantly goes to voicemail to every time. I would like this to be fixed so that if a phone call is sent to my phone it doesn't instantly just send them to voicemail that I do receive it. that maybe there's a way to disconnect the Wi-Fi when it detects a phone call of some sort. I hope I don't have to send any error issues because obviously if I'm connected to Wi-Fi and then it goes to voicemail on their end there will be nothing on my phone. Then I can't show you because obviously I'm not receiving it out. Later I may get a voicemail if they send one but that's all I'll get. This is a very large problem it's something that has gone off and on sometimes I will get a call but almost nine times out of 10 it'll go right to voicemail. I'm in a very good service area most of the time so service is not an issue. I hope this can be resolved soon. The only thing I can say is just connect to Wi-Fi with the device on your end and see if I'm wrong. I don't know how to troubleshoot this because if it goes to voicemail on their end I never know until they physically see me the next time
Thank you

Comments

  • Hi weiss.clayton.t,

    When you are connected to 4G, does this problem appear?
    Do you have landline phone or another cell phone? So you may call your number and check under 4G.

    We would suggest you check Contacts > Three dots on the top right > Settings > Call blocking & block list, make sure not to enable "Block numbers not in contacts" or "Block calls from hidden numbers".

    Thank you :)
  • Lol what a funny response. Ok I have had this device over 8 months and can make plenty of calls on 4g and receive texts just fine. I checked my block list and only have one number that is blocked. So to reiterate, when on wifi, I do not receive calls and there is no way of knowing I don't receive them until I physically talk to the person who tried to contact me. I don't know how else to explain this, but on wifi no calls.
  • *#*#4636#*#* turn off WiFi calling if enabled. It could be bug in VoWiFi settings. 
  • Well very confusing information I looked at. I'm not a programmer, but I found an area that showed that wifi calling was unchecked. So, no change at all. Thank you for the info though.
  • Last edited by Jei_ASUS on 2019/7/2 15:11
    weiss.clayton.t posted on 2019/6/20 20:21
    Well very confusing information I looked at. I'm not a programmer, but I found an area that showed t ...
    Hi weiss.clayton.t,

    Is this problem happening on SIM calling (phone app) or other calling apps as well?
    Could you tell us your operator? Have you tried with other SIMs by other operators?
    Which operator are the others calling to you from?
    Please also check your PM for a message I have sent you.

    Thank you :)
This discussion has been closed.