Network issue when using Wi-Fi

edited September 2020 in ZenFone Max Pro Series
ZF Model: ZB630KL
RAM: 4G
Firmware/APP Version: Android 8.1.0 (2016.1902.192-20190226)
Frequency of Occurrence: every day, always.
Rooted: No
APP Name:

Last edited by speidoeisu on 2019/4/6 22:26

Been using Zenfone Max Pro M2 (ASUS_X01BDA) for about a month with the latest firmware available, and I keep having network issues over Wi-Fi.
I have another phone (the one I used before I went to Pro M2) and several other phones to test from friends (plus an iPad just to make sure) tested with the same Wi-Fi and it connects just fine, plays games and apps without calling out for connection error every few seconds. The same network (from the same router, Huawei HG8245H) was also used for my PC and it shows nothing of the anomaly. Max Pro M2 for some reason just doesn't want to connect to a server properly, I had to reconnect Wi-Fi every often or restart game just to make it go through the server and back. It works fine with mobile data but I can't afford to waste on my monthly quota just to interact with people or play games and losing all my internet quota within days.

The problem doesn't happen to only one or two apps / games, it happens to (almost) every apps that I have.

Additional issue: it will disconnect from Wi-Fi every once in a while and won't reconnect until I hold the Wi-Fi icon to access its menu.

Would be appreciated if there's anyone available to assist me in fixing my issue.
This discussion has been closed.