No SIM card detected

ZF Model: ZB602KL
RAM: 3G
Firmware/APP Version: 8.1.0
Frequency of Occurrence: Weekly
Rooted: No
APP Name:

Bought this phone in February 25th, 2019. The Vodafone SIM card is not detected or it's losess signal (SIM not appear in Settings!). Tried all methods, including factory reset, network reset, Airplane mode, switch SIM cards into their slots. Nothing. Right now the Vodafone SIM it's not detected at all!

I've seen a lot of complaints here since last year, regarding this huge issue and I can't believe Asus doesn't fix this! Asus, you can clasify this as a 'phone" while it's not able to be used for its main purpose: A PHONE!

Comments

  • same as what happened to my phone. and there'a no response from Asus.  :'(
  • Last edited by Jei_ASUS on 2019/3/22 09:13

    Hi marian.cimbru,

    Please check your PM for a message I have sent you. Thank you for your help :)
    Could you check which firmware version you are on? * Find the firmware version in Settings > System > About phone > Build number
    Could you show me screenshots of the problem with no SIM status?
    Does this problem appear in both SIM slots?
    Have you tried a SIM from another carrier?
    Could you tell me your location?

    Thank you.
  • bay1998crb posted on 2019/3/20 13:22
    same as what happened to my phone. and there'a no response from Asus. :'(
    Hi bay1998crb,

    Is your SIM detected as no signal as well?
    Please tell me your firmware version, SIM carrier, location, and show me a screenshot of the SIM status.
    Does the problem appear in both SIM slots?
    Have you tried another SIM card by another carrier?
    Please check your PM for a message I have sent you.

    Thank you. :)
  • I have the same issue with both Vodafone and BSNL SIM cards. I tried the SIM cards on another mobile and it works perfectly. Mine is Zenfone Max Pro M1.

  • same i think happen with me on my airtel sim when i insert it in smartphone phone doesn't recognize sim

    but when I insert sim in small feature phone then its working fine

    so i have restared my sim on same number

    now its working fine

This discussion has been closed.