Asus Weather App and Widget

edited September 30 in ROG Phone
Model: ZS600KL
RAM: 8G
Firmware/APP Version: 5.0.1.20_181226
Frequency of Occurrence: always
Rooted: No
APP Name: Asus Weather

I have noticed that the app isnt functioning as it would come across as how it should work. Now this maybe me miss understanding based on wording used in the application.

The problem: the widget on the home page (once the phone is unlocked) it displays the time/temp/date/location ok which seems to auto update and correct the time & date however the location and tempiture doesnt change at all unless you click on the text which is a shortcut to opening the app and then it refreshes the details in the weather app which they updates the widget.

My understanding of this app is this should be running as a background task to check my location and the tempiture and then updating this on the widget which doesnt appear to happen unless i force it by manually opening the application which defeats the object of the widget.

What i have tried is reinstalling the app itself, clearing out the cache and data and re setting the permissions i dont know why it needs permission to my storage so am testing this at the moment but cant see it will make a differnce but would like to know why storage access is needed for this app.

I can not see that the application is draining any battery life as a background service and settings within the Asus Weather app are set to Get My Location and Update Frequency 1hr. When we had bad weather 2-3 weeks ago i was getting snow alerts / notifciations from the app so some bits of the app are working in the background just not updating the tempiture and location part of the widget even after waiiting 1-2 hours for it to update based on frequncy setting

Comments

  • Hi iStasis,

    Please check if you have allowed "Location" in permissions.
    Have you set your location mode to "High accuracy"?
    Please make sure not to activate "Super Clean mode" in Mobile Manager > Memory Cleaner > Super Clean mode set up > Weather.

    If after that, weather still cannot be updated automatically, you can let me know.
    Thank you :)
  • Last edited by iStasis on 2019/3/4 22:03

    Asus Weather App does have "Location" setting enabled in its app permissions but doesnt have "storage" enabled which is how it was after a factory reset.

    In Location setting (Security & Lock Screen > Location) is set to "High accuracy" how ever looking at the "Recent location request" section the Asus Weather app is not listed so something may not be right here.

    Sorry in the delay getting back as i wanted to check a few things and reset the phone twice over the weekend. It still isnt showing the right data even after a factory reset and google play store updates have hit the phone so maybe something in the Asus Weather app update stopped it? a few people i know who have the phone it doesnt work for them but they dont care too much about it.

    Looking at the below id say i havent actived Super Clean Mode
  • Last edited by Jei_ASUS on 2019/3/5 16:16
    iStasis posted on 2019/3/4 21:55
    Asus Weather App does have "Location" setting enabled in its app permissions but doesnt have "storag ...
    Hi iStasis,

    Thanks for your reply.
    Are you connected to WiFi or 4G when the problem appears?
    Could you show me a short video of the problem when the location and temperature need to be updated after you tap on the widget?
    To share videos, please upload it to ASUS WebStorage (https://www.asuswebstorage.com/navigate/) and share the link with us.

    Thank you :)
  • Last edited by iStasis on 2019/3/6 21:49

    Note really much to video clip and really am not able to take one at the moment and would prefer to not publish my location but the below should help

    1) Factory restore a phone (not sure if latest frimware is a issue but i am not the latest)
    2) When it has had the all the ASUS software updates from the google play store go to the home screen
    3) Note the time and temperature
    4) Wait an hour and don't change location as the apps default is to update hourly automatically. You'll see it hasn't updated the widget as it should do with the new temp (got to bare in mind that the actual temperature has to change in the location best to see it in the morning or evening as this is when it warms up and cools down so should update dramatically at these times of day.
    5) After seeing it hasn't updated either click the bottom line of the widget (shortcut to weather app) or open the app. When the app opens you'll briefly see the time it last updated normally the last time the weather app is open and then it updates.
    6) Rinse and Repeat 3-5 and you'll notice the app when open will show you the time you last started the app to update by opening the app and therefore isn't running in the background as if you leave it 2 hours it will have a 2 hour ago time stamp.

    Looking at the phones background apps and battery usage for the app its very low so to me i see no evidence its actually doing anything in the background and only updating when the apps opened/refreshes/updates on app opening.

    As the Asus Weather app uses accuweather data im going to run both widgets on my home screen for a few hours both updated at the same time and both set to update on an hourly basis which will provde your app is broken. IM sure you could do the same test using accuweathers app too. Seems it needs so troubleshooting
  • Last edited by iStasis on 2019/3/6 22:07

    Also when doing the above check on a different device such as a laptop on the https://www.accuweather.com i suggest their app running along side the ASUS one and looking at their website to see what its reading as the location temp is before opening and refreshing the app.

    If its broken or not working as intended please can you just allow us the ability to keep that clock layout and just turn off the weather feature as its clearly broken and not working 100%
  • iStasis posted on 2019/3/6 22:06
    Also when doing the above check on a different device such as a laptop on the https://www.accuweathe ...

    Hi iStasis,

    Thank you for your feedback.
    A new firmware version WW-15.1630.1902.80 has been released, and we would advise you to update to this version and check if the problem still appears.

    Thank you :)
  • Last edited by iStasis on 2019/3/7 19:57

    Thanks I just noticed the update 45mins ago and just got around to logging on her to see if any of my posts had been replied to ill update my post here and edit this post.

    1) 11.57 location correct (9c) Displayed after new firmware installed so refreshed its data on login after reboot.
  • Looks like its updating on its own as intended give and take the nature of weather apps and widgets. I have gone into the app a few times over the past 24 hours since the new firmware update and looks as though it is updating the Temperature in the widget and going into the app you can see it has been updating itself as the last updated timestamp is when i haven't been using the phone / touched it so looks like its working alot better now. Not sure if you fixed anything or the new firmware including something not published on the official patch notes fixes.
  • iStasis posted on 2019/3/8 19:18
    Looks like its updating on its own as intended give and take the nature of weather apps and widgets. ...

    Hi iStasis,

    Thank you for your reply.
    Please make sure to be connected to WiFi or 4G for the Weather widget to update automatically.
    If the widget is still not updated, please tell me for how long is it not updated.

    Thank you :)
This discussion has been closed.