No Data Signal - Latest Firmware

ZF Model: ZE554KL
RAM: 4G
Firmware/APP Version: Latest
Frequency of Occurrence: 2.22GHz
Rooted: No
APP Name:

Last edited by nathanw.01 on 2019/1/15 23:19

I have a Zenphone 4
Model
ASUS_Z01KD
Ever since the lastest firmware update, I cannot connect to 4G, or use any mobile data.
Wi-Fi is fine.
I can send texts and receive calls fine.
I cannot connect to 4G.
My phone's service status claims:
Voice: In service
Data: In service
Mobile network state:
Disconnected
I have spoken to my network provider, who say that there are no issues with their network, and that other users are not having this issue on other devices.
Is there a fix?
Can I roll back my firmware version?
I may need a temporary replacement if this issue is not resolved.
Thank you.

Comments

  • Hi nathanw.01,

    What is your current firmware version?
    The latest firmware version is WW_15.0610.1901.22,
    if you are not on this firmware we would suggest you update and check if the problem persists.

    If it does, please tell me your network provider.
    Have you tried with other SIM cards by different network providers?
    Have you enabled mobile network in your phone settings?
    Do you have a screenshot of the disconnect error message?
    Please also show me a screenshot of the signal strength (Settings > System > About phone > Status > SIM status)
    What is the approximate location where this problem happen?

    Sorry for the inconvenience.
  • Last edited by daniele.salgari on 2019/2/13 11:55

    i have the same problem as nathan.... last firmware update WW_15.0610.1901.22 no connection on 4G and ofteb it goes on data stand by and i resolve only switching data off and on again... then at my home when there is a good 4G signal now it reach only 3G or H signal.... tried with different Phone and it reach 4G signal without problem with good signal power.
    All these things after the last january update.
    Repeat, with the same Sim Card Operator on other phones everithing works good
  • daniele.salgari posted on 2019/2/13 18:51
    i have the same problem as nathan.... last firmware update WW_15.0610.1901.22 no connection on 4G an ...

    Hi daniele.salgari,

    Sorry for the inconvenience caused.
    Please tell me your SIM operator, and show me screenshots or a short video that exhibits the problem.

    To share videos, please upload it to ASUS WebStorage (https://www.asuswebstorage.com/navigate/) and share the link with us.

    Thank you :)
  • edited August 1

    I have same problem, zenfone zs570kl, sim detect but signal strength 0dbm, 2 slot also sim detect but no signal, why?

  • Hi shahrizansarip83 

    Thank you for your asking. Kindly provide the information below so that we can better assist you.

    1. Does the issue appear after any system/apps' download or update?

    2. Your current firmware version

    Settings>System>About Phone>Software information

    If you try to update to the latest version, does the issue still persist?

    3. Please try to insert the SIM port without SIM card, then put the SIM card and re-insert the port again.

    4. Does the SIM card work with other device? If it doesn't, change a new SIM card.

    5. Please try to enter "Safe Mode". If the function works well in Safe Mode yet the issue remains out of Safe Mode, please check on any disturbance from the installed 3rd party apps.

    # How to enter and exit "Safe Mode"

    https://www.asus.com/support/FAQ/1005163/

    6. Please try reset Network: Settings>System>Reset options>Reset Wi-Fi, mobile & Bluetooth

    7. What's your preferred network settings? (2G/3G or 2G/3G/4G)

    8. Also, please try "the Factory Reset" 

    Settings>System>Reset options>Erase all data(factory reset)

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

Sign In or Register to comment.