Ringtone automatically being reset to nothing on Sim card 1

edited September 2020 in Others
Model: ZE552KL
RAM: 2GB
Firmware/App Version: Kernel version 3.18.66-perf-gc8b1dc7
Location:
Frequency of Occurrence:
Rooted: No
App Name:
Description: Ringtone automatically being reset to nothing on Sim card 1

Hi First post here, hopefully someone can help.

I recently noticed that my phone wasn't making any sound when receiving a call. I checked that the volume and that was fine as my SMS notifications come through just fine. When I checked my Phone notification sounds for SIM card slot 1, I found that i had been reset to 'Festival' which I believe is the default. When I click on 'Festival', I see the list of available ringtone but 'Festival' is not set (i.e the radio button next to Festival is not checked). When I set it to 'Festival' or any other ringtone, the ringtone works again. .. well, until the next day, when I have to do this all over again.


Something is resetting the ringtone every night. This has been going on for about a week and I haven't figured out what is detaching my ringtone?

What I have tried when my phone's ringer is not working.

1. Reboot - This didn't resolve anything
2. Reboot in Safe mode - Also didn't resolve anything.
3. Select Festival as the ringtone (instead of a custom ringtone) - In the morning, the ringer wasn't working again. The radio button on the list of ringtones wasn't set to anything.
4. Is the problem related to charging? I don't think so, as last night I didn't plug in my phone and in the morning the ringtone was once again unset.
5. I don't recall installing anything new in the last week when the problem happened, so I don't think it is one of my apps.
6. Ran two different malware scanners, just in case.. no hits.


I observed that the ringtone assigned to SIM Card 2 seems to be fine, but I don't use SIM card 2. Fine in the sense that it too is assigned to 'Festival' and when I click on that, the radio button next to 'Festival' is set. I didn't test that it actually works since I don't have two sim cards.

I am not suspecting it has something to do with the Do Not Disturb mode that is automatically triggered every evening. I am going to disable that tonight to test. When I manually toggle DND it didn't disable my ringtone so perhaps the automated DND is responsible?

Any ideas? could it be a bad SIM card? Anyone else having these gremlins?

One last thing in case my settings don't get posted.

ZenFone3-ZE552KL (NOT rooted)
Android version 8.0.0 with the latest pushed updates as far as I know.
Kernel version is 3.18.66-perf-gc8b1dc7

Comments

  • Hi nelsonppereira

    Good day
    Please try to put the sim card in SIM card slot 2 for a check.
    If the issue is still not fix please backup phone date and factory reset. In order to exclude caused by software.
    Thank you and have a nice day.
  • Thanks Selena_ASUS.

    I haven't been able to repeat this issue over the last few days so perhaps the issue has resolved itself much in the same manner it manifested itself -- mysteriously. As it currently stands, the custom ringtone has not been reset for a few days now. I don't know if all my reboots made any difference or if toggling the Do Not Disturb on and off, toggling bluetooth did the trick.. Nonetheless, the ringtone has stuck and the phone is behaving normally.

    If it does come back, I will certainly try your SIM card slot 2 suggestion and post results.
  • I spoke too soon. The same issue resurfaced once again this morning.

    I opened up my SIM card slot to try your suggestion of moving the SIM card from slot 1 to slot 2. Unfortunately, the SIM card slots are not the same size so I can't do that and I don't want to buy a new SIM card just for testing this as I am not convinced this would be the issue.

    I will keep poking around to see if I can find out what the cause is and if I happen to find it, I will post to hopefully help someone else having this problem. I am actually surprised that I wasn't able to find anyone else reporting this, so I fear that this is an isolated issue.
This discussion has been closed.