Why is that my camera does not autofocus on things only if i touch it on the screen?

edited September 2020 in ZenFone 6

Why is that my camera does not autofocus on things only if i touch it on the screen? The photo is obscure, not sharp if I don't focus manually on something, even if I turn on the pre-AF.

I attach 2 photos, the difference is if I touch the screen to focus on something.


Comments

  • Clear data to Camera app and test again.

  • Nothing changed

  • Then all you have to do is try the factory reset and if that doesn't help the service.

  • Could you try to screen record the camera app when you are using it.

    And also go into the settings ?


    Also try Pro Mode?

    Turn on Auto Focus and try to focus on something close for 3 seconds, then move to something furhter away, wait 3 seconds.


    You already tried to clear settings per Jis suggestion but I would like to ensure that it isnt the "camera settings -> reset default";

    Please clear the settings by going to the home screen, find your camera app icon

    Long press the Camera app icon

    Press " i - App info"

    Storage & Cache

    Clear Storage

  • Now it works, thank you

  • M.KM.K Level 1
    edited January 2020

    I have the same issue...

    After receiving my phone back from the service center for a motherboard replacement (https://zentalk.asus.com/en/discussion/14763/dead-phone-after-update-from-73-to-110), I noticed that the auto focus was, most of the time, not working.

    The auto focus was working perfectly before, on version .73. Now it's broken on .119.


    Tried to clear storage and cache of the app, not working.

    Tried in pro mode, not working.

    Tried to factory reset, not working.


    I really hope that it is a firmware issue...

    You can see a screenshot of the app settings and a video screen recording sample:



  • Try to factory reset your phone. It helped to me.

  • M.KM.K Level 1

    I did it twice already, it doesn't work.


    The issue seems to appear less often when I am taking pictures in an outside area.

    It seems to appear way more frequently at short distances (1, 2 meters), or in indoors area (a few meters).

  • My problems were the same, only indoors

  • CH_ASUSCH_ASUS admin
    edited January 2020

    It .. seems focus itself is changing, so the af-motor at least is working , somehow.


    1.

    Can you focus on a wall, say 2-3m away.

    Then put your hands in front of the camera - 30cm away from the camera .

    And using the main camera (as your video).



    2. What about "touch to focus". Can you try that too?

This discussion has been closed.