Does not charge beyond 60-64%

SantaClawSantaClaw Level 1
edited September 2020 in ROG Phone 2

Well, I woke up today only to see that the phone had dropped down to 56% charge despite being plugged into the original charger using the original cable for the last 6-12 hours. I tried changing to another cable, and I tried a different charger, if the phone is in use, just typing this, the battery actually drains even though it's plugged in. I tried restarting the phone. There are no apps running in the background.


I tried the side port, and it did not seem to charge any faster. In the battery app, it's stuck at "Will be fully charged in 1 hour 21 minutes"


I'd like to ad, that the other charger is the stock Razerphone 1 charger and cable, and the two lightning symbols come on.

Comments

  • DONT USE OTHER COMPENYS ADAPTER IF U WANT U CAN USE CABLE CUZ IT CAN AFFECT UR BATTERY LIFE.

    and as for ur problem does battery stop charging at 56%??

    Can u send the photo of apps draining battery while charging??


    Did u try clearing total cache of the phone ??

  • It's a high quality quick charger with USB type C like the OEM asus charger, I see no reason why it would harm the battery. It' not as powerful as the original charger either, I it's only 24w (12v 2A) vs the original asus charger at 30w (12v 2.5A). The "charger" only provides 12V DC the phone draws what it needs up to the max of what the charger can deliver, filters it, converts it to what the battery needs during charing, most likely 4.2v or there abouts and charges the battery with slower and slower rates as the charge builds, in other words, the actual charging circuit is inside the phone. Unless you have a faulty/shit quality charger putting out "unclean" or too high voltage, there is no danger of damaging your phone at all.

    The battery peaks at about 62% it does not charge above that.

    I typed the message out on my phone, while I was doing that it dropped from 63 to 61% despite being plugged into the original 30W charger and using the original cable, the phone is less than 1 week old, and I have never put any strain on the cable..

    And in case you claim I should use a different charger than the 30W one, it came with my phone, I have the 1 TB 12GB ram Ultimate edition.

    Shutting down, and restarting the phone should clear anything that could be cleared. Yet, it made no difference.

  • Aryan202Aryan202 Level 5
    edited January 2020

    Two lightning symbols= it's fast charging

    Mostly it's the issue with cables (the stock one is indeed a bit flimsy and prone to failure)

    Adapters are rarely the issue

    But only as a precaution check if you scheduled charging on

    It's in the mobile manager>power master section

    Try toggling it on/off

    Secondly you can try clearing mobile manager app data/cache

    Sometimes a simple restart or booting the phone in safe mode for a while helps too

    If those don't work the mods will probably sort it out for you

  • Did u try using 18 w Asus charger??if not try and see in that

    And try erasing total cache of the phone .

    Otherwise u need to reset i think.

    If even that didn't solve ask Dev's or go to service center

  • SantaClawSantaClaw Level 1
    edited January 2020

    I found a fix, I used the Razer charger, and the razer cable, that seemed to work, I think there is an issue with the 30w charger, as I can't get the razerphone to charge properly with it either, It worked in the past.


    I don't have a 18w asus charger. My phone didin't come with one.

    And yes, I have adaptive charging on, from 22:00 (10 pm) to 08:00 (8 am)

  • Great Job! this fix might give some other users some hope!

    I am using the 30Watt charger than came in the box with this cable and it has been working for me!


  • If it is a defective charger, the warranty will cover a replacement. Please get in touch with your local ASUS support to arrange that.

  • Will do, It's easier for me to contact the local franchise of the store chain I bought it from though, as it's covered by both warranty and Norwegian consumer protection laws..

This discussion has been closed.