Still unable to connect Bluetooth headphones after 119 update

edited September 2020 in ZenFone 6

I have a pair of JLab Air Icon headphones I was able to connect to the Zenfone 6 before the Android 10 updates but since the Q update, I haven't been able to connect to them at all. Sometimes it shows invalid pin, other times it just tries to connect for like 5 minutes but then won't. I have other devices connected through Bluetooth, including a pair of Skullcandy Push headphones, car stereo, and a Steam Controller.

Comments

  • I have the same issue with my Philips Upbeat SHB2505.

    It worked on Android 9 and hasn't worked on any version on Android 10.

  • And these headphones pairs perfectly with other devices? Have you made sure to forgot the headphones in settings before trying to pair them again?

    You could try and go to system settings -> system -> reset options -> reset wifi, mobile, bt

    Hope one of those helps

  • I was never able to get those headphones to connect. I ended up buying a new pair of different earbuds which seem to work fine.

  • edited January 2020

    From your description, and this is VERY common with BT headphones, I can imagine you "think" you have your headphones in pairing mode but you probably do not and they're still locked to your ZenFone 6 running Android Pie. Have a look at the manual on how to force them into pairing mode https://cdn.shopify.com/s/files/1/0240/9337/files/JBuds_Air_Icon_Manual.pdf

    It would be a shame to stop using them just because they're locked to a device which no longer exists. It probably sees your ZenFone 6 with Android Q as a new device.

  • With my issue the headphones worked with my friends O+6 and my other friends O+7 Pro on A10. I even did a factory reset on the phone, nothing worked. It's a ZenUi A10 bug.

This discussion has been closed.