Zenfone 5Z Mobile Radio Power OFF

chrymtchrymt Level 1
edited September 2020 in Fan Chat

Hello Friends,

Suddenly I lost Mobile network and calling facility on my Asus Zenfone 5z. I recently upgraded to Android 10 so I thought it is a bug. But I did factory reset and even downgrade to Android P by following guidelines in Asus website but Mobile network issue persists. I can't call or use Mobile network!!!

The SIM perfectly works in any other phone. However if I put any SIM in my Asus Zenfone 5z the issue remains same.

After dialling *#*#4636#*#*, I found Mobile Radio Power is OFF. I can easily toggle it to ON but it reverts back to OFF immediately. The issue persists even I restarted my device in SAFE mode, turning Aeroplane mode ON/OFF every possible option.

Currently I again upgraded it to Android 10 but same issue.

Any help?


  • Same issue is occuring with my Asus 5z phone .I have updated my phone to android 10 few days back but suddenly radio signal is lost. Did you find any resolution .

  • I have a link but cant post it here as ZenTalk won't allow me to.

  • I too have the same problem. I did a trick from XDA forum. Not sure it will work for you.

    Prerequisites: update software to (I did it manually)

    1.Drain your battery to 4 percentage and turnoff your mobile.

    2.Then restart in download mode( press volume down and power button simultaneously).

    3.Then in download mode wait for the battery to drain out completely.

    4.When battery runs out of power press the power button again to see that baterry is fully down i.e no response while clicking power button.

    Final step recharge your phone upto 10 or 20 percent and turn on your mobile. And wait for sometime. The XDA author says by doing so the radio component resets completely. I am not the author. But it worked for me.

    I tried this method two times. Not guaranteeing anything. No harm in trying when official service assistants doesn't help much. All the best.

  • MuheetMuheet Level 1
    edited July 2020

    android 10 latest update ....asus 5z....same issue here.....i reset the networks after reseting i lost networks....it is coming and going...networks are on or off......unstable i tried evwry ppsible option factory reset.....now i dont knw what to do...i m frustrated.....please anybody has solution will b appreciated.....please let me know if its software issue or hardware....thanks

  • After trying various several steps if your issue still exists than it seems its most probably hardware issue as antennas may have been loosen up having connections with sim tray

    I recommend you to kindly take your device to nearest service centre for examinations and fixes

    Note:- dont forget to backup your imp data before you submit your device to service centre

    thanks! 😊

  • same issue since 2 weeks. its as good as i dont have a mobile phone. I have spent so much time to get a fix but nothing works. ASUS has proved to be a poor decision to own. i have a 5z. I am always going to steer away from every electronics that has direct or indirect relation to people who cant open their eyes wide

This discussion has been closed.