Contact edit not working

PowerCatPowerCat Level 1
edited September 2020 in ROG Phone 2

So I tried to change a name in my phone contact but but it still shows the previous name even though the edit shows the new name.

Comments

  • Can you please make a video using the screen recorder?

    Is this a google contact or maybe via some microsoft exchange?

  • It seems whatsapp was the reason.

    I deleted the contacted and then just added it again

    Seems to work now.

  • Strange that Whatsapp would effect your contacts. Could be a permissions issue.

  • If I create a whatsapp account for a person that is not already in my contacts list and sync that with my google account, then our contacts app will find that contact right away. No need to create a new one and I have no problem changing the name in our contacts app. It will display the same in whatsapp.

    So I'm wondering if it could be that you're using one google account for whatsapp and another account for your phone (contacts app)? If this is the case, then the bug could be that when you create an account in your contacts app with the same number as a contact in whatsapp, then maybe it fetches the info from there instead.

    I don't have two google accounts so I haven't tried if this could be the case.

    Or did you store the contact on "this device" on either whatsapp or the contacts app?

  • I don't remember now.. but most likely I saved it through whatsapp

  • My issue is related to this particular bug but mine will not save the name of the contact I entered and it will only use the phone number. See screenshot attached. I thought it's phone book specific, so I tried to save the contact via sim, device or email but they all give the same output.




    Some of my contacts with the same problem were shown properly after I updated the firmware, seems like it's flashed but the problem still exist on the new firmware. Please note that it's been a bug before I even installed other apps. This has happened on my 8GB and 12GB version of ROG2 both have global rom.


  • Try deleting the contact and then saving it again. It worked for me .

  • So you're saying that you already had this contact in whatsapp? Because it should show up right away in ASUA Contacts app as connected to whatsapp but in your case it doesn't

This discussion has been closed.