Rog phone 2 notifications delayed or none existent.

Hi all I've had my Rog phone 2 for about a month now and I've noticed a few problems with it.

1. Notifications - little or none existent, the notifications come through very slow or not at all. I read that you have to go into battery settings and auto start master. However I'm not convinced that has fixed it. If I connect to WiFi my notifications start rolling in. I've never had a problem with notifications, something a cheap smart phone can manage instant alerts, but this phone seems to drag. I was really excited about this phone and would like to get this problem fixed asap.

2. The space-bar - writing messages whilst typing fast, I occasionally press the smiley face icon left of the space-bar and during the texting war would send all kinds of .gif moving images and it's really annoying. Perhaps moving from IPhone to this Asus android phone a little different but the space bar is so small! Not ideal for my sausage fingers but wondering if I can get it adjusted or download another keyboard.

That's all I have for now, appreciate if someone can guide me in the right direction as I use this phone for work and instant notifications are a must.

Comments

  • 1.) Users with similar SMS issues were sometimes able to resolve it by getting an alternate SIM card from their carrier. Are you saying you aren't getting any mobile data? All SMS messages and app notifications are delayed until you use a Wi-Fi data connection? I would be looking at getting an alternate SIM card and testing it in store if possible. Have someone send you a text and and email and trigger an app notification. Setting an APN for your carrier may also help. https://www.asus.com/me-en/support/FAQ/1038397/

    2.) I feel your pain, I just made the switch from an iPhone 6 to a Pixel and I have been having the same muscle memory learning curve. If you don't like using Gboard, you can try Swiftkey. To be honest I'm not sure if the space bar size is different, but I know Swiftkey has a bunch of customization options.

  • Hey @EmpireSA

    With regards to the notification delay issue, I've had the same issue. After many trial and error, I've discovered that it was due to Android 9 excessive battery optimisation settings. You'll need to go into Settings > Battery > Battery optimisation > All apps then find each apps that you would like to be able to run in the background so you can receive notifications while on mobile network and disable Battery optimisation. It's painful I know but it works.

    The alternative is to set X Mode on all the time which put it into high performance mode but that really chew through your Battery.

  • LP_Asus & Cathlyn,

    Hi thanks for your reply, yes when I connect to WiFi my notifications come through for example I use a WiFi camera app and when I connect to WiFi I know I'm getting 10 or more notification sounds but strange because I already did the battery optimisation and ticked the boxes I want to allow, plus other apps to run in the background. But that didn't cure it. Another problem I noticed is YouTube app almost never works on mobile data I have no idea why. So the Answer to LP_Asus yes I get some mobile data, Google search app works perfect, just wouldn't hold my breath with the notifications coming through. I may try another sim card because I really need to receive prompt notifications. And be able to use YouTube app on mobile data.

    Not sure what an APN for my carrier is I'll have to read up on that.

    2. Thanks I will try out some keyboards to suit my style of typing.

  • I had this issue and finally fixed it.

    1. Delete the cache of all your Google apps including YouTube, Google, play store play services etc.

    2. Go to settings, apps and notifications, see all apps, 3 dots, reset app preferences.

    3. Reset your apn and reconfigure it.

    6. On your apn settings under apn type, enter "default".

    4. Go to settings, advanced, mobile manager, data usage, control app data usage, untick all from wifi and then tick all, go to mobile data and again untick all and tick all.

    5. To check if it worked disconnect from wifi, go to the dialer and dial the code *#*#426#*#*

    If it worked you should be able to connect to Google servers.

  • Hi Vaxaviv I did all that and it's still not working I got this when I called #*#426#*#

    See attached.

    Maybe I should change the sim card but never had any problem with my previous phone.

  • There is another possibility, you have the tencent edition device with WW rom but the fingerprint is still configured on CN

    If you want to test it download an app called "Device Info HW" from the play store and check under "system" the fingerprint field.

    That also happened to me because I bought my phone from bangood and they installed the WW rom without changing the fingerprint version, I heard on xda this can cause the issue.

    If this is your problem let me know and I will help you to fix it.

  • I did what you said and i've screenshot if that means anything to you.


  • Yes, CN fingerprint...

    You need to change the fingerprint to WW.

    Is a bit complicated and in not sure if I can link something from xda forums here but there is a guide there on how to do it without root and without unlocking the firmware.

  • Ahh, you have a Tencent edition phone. That makes things a lot more complicated. Refer to the sticky for more info. vaxaviv's advice is also relevant, but I can't provide official advice on how to change the country code unfortunately.

  • Oh dear so I've bought a phone that doesnt work properly in the UK? I wonder if Asus support can help me. What do you mean refer to the sticky for more info? Can anyone help with this issue?

  • Yeah. It's a version designed for china only, different LTE band too. There's some fix if you can't return it. Change the fingerprints like vaxavix said but it's not official fix so no Asus support (there's non official forum but you'll lost warranty even the Chinese one). Or change rom back to CN, the easiest is download the latest version of CN ROM from here. I think WW is at .44 and CN is .52. Put the file in phone root folder (basically not in any folder) and restart the phone to see if it update by itself. If not then the seller messed a bit too far and you do have be to flash raw CN ROM. Good luck.

  • Ok thanks for your feedback I will have to try a few things, but when I bought it, it did say tencent version which mean nothing to me but now I have to live with that.

  • Sorry EmpireSA, I was running out of time last night but wanted to respond. The sticky thread is here. https://zentalk.asus.com/en/discussion/10259/psa-take-caution-tencent-branded-chinese-models-with-global-international-rom#latest

    In a nutshell, ASUS Support can't really help you. Anything we do to help has a very high risk of damaging the phone or introducing more software errors. I also wouldn't recommend going back to the CN firmware, because you would lose access to all Google services (kind of important for an Android device). I wish I could do more to help.

    If possible, try and contact your reseller and see if there is any kind of return option available.

Sign In or Register to comment.