Fast charge not working anymore on my Zenfone 6

Hello I have a very big issue with my phone..

3 days ago I left my charger at work, so when my phone completely discharged to 0%, I had to charge it overnight with a non-fast charge adapter I had at home.. it took all the night to charge to about 70%.

Yesterday I brought back my original charger & cable and to my dismay fast charge isn't working anymore !!!! It is just like charging with the other adapter. Please help !

Comments

  • Check if cable can pass data. If can pass data, then problem lies elsewhere than phone and cable, which means fault is charger.

    Check if charger can fast charge other devices, if can, it means the problem comes from phone.

    Try and find which link of the chain is the problem

  • bbbbbb Level 1
    edited November 2019

    For me Quick Charge stopped working with ROM WW_17.1810.1910.68

    I have blitzwolf BW-S7 charger + Orico KAC-05-RD cable

    With Xiaomi Mi8 QC is working.


  • Try not to use third party charger if you can, it may be incompatible somehow after update / somehow it works in the past but now no more. It seems to be that ASUS implementation of QC is much more fragile and unstable than other device. If you check my previous post you'll know I once fried the phone due to power bank not exactly to spec.

    Now, the problem must lie in: incompatible charger / phone problem. Guarenteed cable is working

  • bbbbbb Level 1

    I don't know where the ASUS charger is, maybe at work. I have a Lenovo SC-42 charger at home. Test results same asus slow charge a Xiaomi Mi5, Mi8, Redmi Note 7 quick charge.

    My tests prove that ASUS has problem with QC.

  • If so many devices can quick charge while Asus fast charge, suspect faulty Quick Charge handshake. Please try and see if you can transfer data to your computer using the cable you used for quick charging other phones. I suspect broken data pins if Asus fail to transfer data, and broken power management chip if Asus can transfer data.

  • bbbbbb Level 1

    I continued testing it turned out that changing the cable to ORICO HTK-10 helped.

    However, I do not quite understand why quick charging does not work with Asus Zenfone 6 + cable Orico KAC-05-RD.

    The producer writes "ORICO KAC-05 5A Aramid Fiber Braided Type-A to Type-C Charge & Sync Cable 50cm" (I have several such cables.)

    Now Quick Charging is working with Blitzwolf/Lenovo charger.

    Thanks for your help.

  • Just saw this Reddit post recently. Follow instructions with some common sense to see if the problem lies there. No way 1 cable can charge while another one cannot, they are the same physically and electrically.

  • Thanks for your replies but for some reasons it got back working when the charge was somewhere between 70 and 82 percent but it took about 7 hours to get there.

    So I recommend doing the following if the same case as mine occures to you:


    1. Drain your battery to 0%

    2. Charge it all the way to 100% whilst the phone is turned on and see if it start fast charging at some point.

    As someone pointed out above I think it has something to do with QC handshake failing to init for some obscure reason. Hope Asus address this issue in future updates.

  • no have problem 20 - 100% 1hour30 min cca

  • Pl also check your adapter is charging properly (giving out required power) by connecting it to some other equipment or device.

    Myself and also a frnd of mine who bought the fone together with me are facing the same issue of adapter not working.

Sign In or Register to comment.