Brand new Zenfone 6, keeps disconnecting and reconnecting to network

I was so excited to get a the 6 as my current phone is just way too slow.

I installed all of my apps, did a data transfer from my old phone, then put in my sim card. I found that the phone keeps disconnecting the shortly after (2 - 10 seconds) reconnecting to the network.


Old phone: Asus Zenfone 3 Zoom. Never experienced a network connection issue in 2 years from this location (my house).

New phone: Zenfone 6, 8GB 256GB. Android version 9. No updates available.

Rogers network. (sim is about 2 years old and has been in and out of the phone a bunch of times so there is a bit of wear markings on the contacts.

So far I've rebooted, checked for updates, rebooted the phone, removed the SIM and cleaned the contacts. I've only used it in SIM 1 and removed the SD card just in case it somehow conflicted.

Did I manage to be the one unlucky person to get a defective phone or is there something else I can do?

Comments

  • For reference, sometimes this will happen 10 times in a row within 2 minutes. Other times, it won't happen for about 15 minutes, or any mix of times/loss of connection.

  • cobbencobben Level 2
    edited November 9

    First above all you should get a new sim card from your operator.

    We have had several weird problems that have been caused by the sim card.

    Once the girl in the shop took one look at our old sim card and said;

    "It's scratched the wrong way - it can be scratched this way, but not that way."

    Go figure.

  • Like Cobben said. Try a new or other SIM. If that doesn't help, then please contact ASUS Support

Sign In or Register to comment.