Hotspot allowed devices

OPCOPC Level 4
edited September 2020 in ROG Phone 2

Testing the WiFi hotspot with my MacBook Pro the connection was instant. Everything worked flawlessly.

Selecting the option "Allowed devices only" it was not possible to add new device. Tapping on the option "Add devices to this list" nothing happens. That is the case with both my MacBook connected and disconnected as well. If connected selecting the "Allowed devices only" option the MacBook disconnects immediately.

The option to add devices is in white colour and thus available. But it doesn't react on tapping.

Bluetooth tethering also works flawlessly.


  • Thanks for this bug report.

    What option did you use to originally tether the MacBook?

  • OPCOPC Level 4

    WiFi hotspot works flawlessly. In MacBook network settings I choose Rog phone 2 as a WiFi network, put in the password required and connection is immediate. Surfing on Mac with Safari is flawless wether the phone is on WiFi or 4G. The same if the MacBook has been directly connected to a home WiFi network. No loss in speed. As a network option on Rog I have chosen 5GHz.

    The same goes for Bluetooth tethering. Pairing is immediate. Connection is also immediate, browsing the web is little slower than over WiFi hotspot, which is normal.

    The only thing on the phone, in the submenu of the "Allowed devices only" option, when I want to add my MacBook as a trusted device, nothing happens when tapping on the "Add device to this list" option.

    Off topic but you might find the feedback useful, today I have used my phone for the first time on a business trip. Phone was taken off the charger at 6am. It has spend 7 hours attached over Bluetooth to my car. Had at least 3 hours of conversation. Downloaded emails, replied to emails. Browsed documents and photo gallery. At the evening using Google maps to find the hotel. All that in roaming over 3 countries. At 10pm the battery was 71%. Just amazing as a business phone. In my case no drainage issues at all. This is the first time I am experiencing this kind of freedom from the charger in a smartphone.

  • Ok thank you for the detailed breakdown, I'll pass this to the software team. Good to know that it's functioning well, even if the UI is a little janky.

    That's awesome to hear on the battery life! I had the same experience when I started test driving the ZenFone 6. I went from a 1700mAh battery to the 5000 mAh on the ZenFone. I haven't had a chance to test drive the ROG Phone II but I can imagine the 6000mAh can make the phone an every other day charging device. I hope we see more phones on the market prioritizing larger batteries in the future, as a consumer I have been looking for this trend for years.

  • OPCOPC Level 4

    Rog 2 is the perfect phone in every way. Flat screen, front facing speakers with amazing sound, headphone jack with DAC (I have wired audiophile headphones which I don't want to give up and I get amazing sound considering it's a phone), small bezels and no notches (I have been playing around with Note 10 and as much as the screen is beautiful, there is no way to hold it that my fingers don't cover a portion of the screen. Also I tried playing games on and that punch hole just ruins the experience), amazing battery, 120 Hz refresh rate, great camera in manual mode which give me great results (the hardware is there and the software can always be polished up). So please keep up the good work and don't fall under trends of bezel less and jack-less fashion. Please zoom in and check the sharpness of this photo in 48mp mode.

  • Well Said. I dont like notch phones and phones doesn't have headphone jack. Having small bezel like Rog 2 is good for landscape apps and games. We have some bugs which frustrate some users and that can be rectified by ASUS developers. Overall, Rog 2 design is great with good hardware. Keep it up ASUS.

  • I don't know if you have already cracked it yourself but you're supposed to press Wi-Fi hotspot users to add devices. Maybe not the best UI design but it's not a bug. We have forwarded this to our devs.


  • OPCOPC Level 4

    Thanks Anders_ASUS! I didn't find it myself. But now it works. I suggest tapping the "add devices to this list" opens the window "WiFi hotspot users" and lists devices that are visible but not yet added.

    And I like the UI design in general. Much more straightforward than for example Samsung. That was my first Android phone after iOS and I was so confused with options overlapping between Samsung and Google that almost got back to iPhone. Here the transition would be much more simple. Rog gives me no nonsense straight forward experience which is good. I know it's not ethical talking about other brands, but I believe if you know exactly what I mean you can understand better.

  • @OPC , the software team just let me know this issue should be fixed in the next FOTA. If you'd like, please test on your setup and verify that we resolved this for you.

  • OPCOPC Level 4

    Ok I am waiting for the new update. I expect it any day now.

  • OPCOPC Level 4

    I can confirm that this option now works. Going into "allowed devices only" and tapping on the option "+add new device" you can now select devices you want to add. I now have 4 devices added.

    To make the test of the hotspot I ran a YouTube video on the Rog 2 and 3 other phones in the same time. No glitches whatsoever. The flowthrough of Rog's WiFi antennas is amazing.

    Off the topic, I made another business trip yesterday. Took the phone of the charger at 5.30am. The battery was at 86% due to scheduled charging and battery care. My battery is scheduled to be full at 7am. Worked on the phone the whole day, used in car Bluetooth etc. Came home at 9.30pm and had enough battery to play Asphalt 9 for an hour before battery droped to 10%. Amazing! No apps draining battery. I use WhatsApp and others all the time.

    The only issue I have is the lack of VoLTE, although the phone has all LTE bands used in Europe. I trust in Asus it will sort it out. Then it will really be a perfect do it all phone.

This discussion has been closed.