Texts not working

mizflores60mizflores60 Level 1
edited September 2020 in ZenFone 6

My text messaging suddenly stopped being able to receive texts from others, yet I can send mine!! Help!


  • Try toggling airplane mode and then restarting the device. I recently took a flight, and after landing when I turned airplane mode off it struggled to reconnect to my network. Restarting the device solved the issue.

  • I'm in the same boat, when I'm at home I can send texts and make calls, but cannot receive either. I get pretty terrible reception at my house (with Straight Talk) so I'm gonna try switching phone service even though I had zero issues with reception on my previous phone which was a Moto G5 Plus. I love this phone's performance but unfortunately if I continue to get bad reception because of the lack of bands on this phone I'm gonna have to return it.

  • You could try and move your SIM from slot 1 to slot 2. If that doesn't do anything. Try the SIM in another phone and see if that phone can receive messages. Then you put the SIM back in your phone and see if it still behaves the same.

    If there's no change, then you could try with backing up your SMS and then find the messenger app in settings -> apps & notifications ->see all apps -> in the top right three dots menu, press show system -> find and press messages (not messenger from FB) -> storage & memory -> clear storage. Not test receiving an sms again. If it works, then you can import all your backed up messages and test if you can receive again. If it never works, then back up everything and reset your device

  • Spent a couple hours and did all that, sim card works fine in my old phone... Still the same problem, except now I'm not receiving texts at all, regardless of where I am or what my reception is like. Hopefully switching to this new phone carrier solves the problem, if not then returning it is my only other option.

  • Did "all that" include a reset of your device?

  • Yup, not sure why it didn't quote your whole post. I've even tried using different APN settings, not sure if that even really changes anything but I'm pretty desperate at this point. Have also tried different SIM cards from Straight Talk. Here's hoping T-Mobile will be my savior.

    edited October 2019

    APN settings have been helpful with other users, at least in Europe. They also helped me in Japan, though not with this specific device.

    Good luck with T-Mobile! For what it's worth, I'm on AT&T and have had no issues, but another AT&T user in Chicago has had issues getting LTE coverage. It seems to also be dependent on location and carrier reception.

    *Edited for poor grammar

  • Fwiw I was using the AT&T SIM from Straight Talk which uses their towers but I understand that Straight Talk has different bands. I did purchase an AT&T byop kit and tested the signal with that SIM and it seemed just as bad from what I could tell so didn't end up making a full switch. According to willmyphonework.net and having the version C phone in the US it seems T-Mobile is my second best option next to AT&T.

    edited October 2019

    Understood. Please update this thread if there is anything we can do to help troubleshoot potential connection issues with T-Mobile's network.

    I'm not sure if this is an option in store, but I wonder if the sales staff would let you use a test SIM in store before you committed to a contract. At least you would know their SIMs work in your area.

  • So would like to provide an update, I am currently doing a 7 day trial period through T-Mobile and so far so good! Have been getting good reception everywhere I've gone today including my house (and basement) and various places around my city. Haven't dropped or missed a single call or text yet so definitely seems very promising so far. So from what I've gathered so far this phone and Straight Talk bands just don't mesh well, but all has been fine thus far through T-Mobile. Appreciate the suggestions LP and Anders, looks like this phone will be staying with me afterall.

This discussion has been closed.