Zenphone 6 wide angle camera not working

nick.seymour78nick.seymour78 Level 1
edited September 2020 in ZenFone 6

This morning I've noticed when I open the camera there is no toggle switch to choose the wide angle camera.

I've run a test through the calculator system tests and it's coming back as failed.

The phone doesn't seem to think it has a wide angle camera anymore. I've restarted the phone and I'm loathed to do a factory reset as I can't see how this would fix the issue.

Has anyone else had this issue or know how to get the phone to use the wire angle camera lens.

Cheers.

Comments

  • Does any camera API checker app detect two modules? Could you provide a screenshot from camera UI?

  • Sorry to be dumb but what's an API checker? If I have one I'll check and let you know. Cheers.

  • Camera doesn't show toggle switch to change to wide angle lens. Pictures above are from the cameras API. Hope this helps.

  • Any response or acknowledgment of this issue would be greatly appreciated.

  • Sorry for not clarifying. Camera2 api check is a kind of app on Play Store. Displays info about Camera hardware and supported features. I didn't need camera app package inspection :p That's really weird that app detects lack of camera and doesn't actually crash.

  • Do you need the screen shots from Camera2 API check? It seems to show the camera has been detected. But doesn't show.

    Do you think a factory reset will in any way help?

  • Either a factory reset if you are on .193 or an update to the most recent firmware would be my suggestion. Are you on FOTA Version WW .193? A factory reset or update should wake your phone up from whatever kind of wide-angle nap it's taking.


    https://www.asus.com/us/Phone/ZenFone-6-ZS630KL/HelpDesk_Download/

  • How do I check what version of the firmware I have please?

  • In Settings>System>About phone>Software information, you will see some information. You're looking for the region and last digits after the last period. For example, my version is WW_16.1220.1908.189_0. So I'm on the worldwide firmware, version .189.

  • I've managed to find the firmware version and I'm on .193, so looks like a factory reset. I'll be back to tell you if it's worked.

  • Factory reset didn't solve the issue. Camera also kicking out camera cannot open error when I use the camera now.. help..!!

  • ColorSageColorSage Level 3
    edited October 2019

    Unfortunately, I don't think we can help you in any way. You should contact service.

  • As ColorSage noted, I also recommend contacting ASUS Support for repair service.

  • Details please?

  • This is the official Support site for ASUS USA.

    Depending on your region the process may be different, but in this region you can use the Support site to register your serial number and request an RMA. It also has phone contacts if you would prefer to speak to someone over the phone.

    The Online RMA FAQ is here: https://www.asus.com/us/support/article/818

    If you are unsure of your warranty region, you can PM me your serial number and I'll check the location for you.

  • Well that's a bit of a pain.. anyone know how much this might cost.. won't be buying a phone off Gearbest again.

  • You are not the first one buying a phone via Gearbest then having problems with RMA. You could try to request repair from your seller but it's hard to predict how much time it'll take to get the phone fixed.

    Adressing service pricing, you should ask Asus Service in your country.

  • Hai ,i m also facing this problem since a month. Ultra wide angle toggle is missing in camera app. I waited for 2 updates.today (31/jan/2020) i got a optimization update and still not rectified. Pls kndly help me in this regards. Thanks in Advance

This discussion has been closed.