What a mess!

135

Comments

  • cobbencobben Level 2
    edited November 2019

    My Z6 30E is still working fine.

    I have the same GPS hardware version

    I get an average "Error" of under 3m. just now with the GPSTest app, less than with my old Xiaomi (4.3m).

    Whatever that means (in SE Sweden).

    I did get rid of the Chinese flipcase with the strong magnets.

  • In the first message you can see a capture of that application. The red balloon is the authentic position of the device. The blue dot is the position that indicates the GPS as authentic. The blue area is the precision zone estimated by harware. And as you can see there are 22 meters of difference between reality and the authentic position according to the GPS.

    I have tried in other places, and the error is not always in the same direction (north, south, east, west), but it is a distance of about 20 meters.

  • In the first message you can see a capture of that application. The red balloon is the authentic position of the device. The blue dot is the position that indicates the GPS as authentic. The blue area is the precision zone estimated by hardware. And as you can see there are 22 meters of difference between reality and the authentic position according to the GPS.

    I have tried in other places, and the error is not always in the same direction (north, south, east, west), but it is a distance of about 20 meters.

    Is there another application that does not use Google Maps to perform another test?

  • cobbencobben Level 2
    edited November 2019

    Herr is mine done just now.

    It starts out with an "Error"of 5-6m., and after 10 minutes or so gets down under 3m.

    My error in fixing my actual location might be 1m. or more.


  • fjaviergjfjaviergj Level 3
    edited November 2019

    Your test shows acceptable performance.

    Can it be a problem with Google Maps and Google services in my area?

  • You are not using Google Maps when running only this GPSTest app.

    There are some other problems in Sweden with Google Maps, but not GPS related I think.

    I haven't been travelling much at all since I got the Z6, but it worked fine with Maps the few times I tried it.

  • I have tried the HERE We Go application, to avoid it being a Google Maps problem, and it has the same problem as you can see in the image.

    I don't know what the problem is so that the GPS doesn't show the true position.

  • Wel,, I am not an GPS expert.

    You might try turning off "Google location accuracy" in the settings, so your device is only using the GPS, and see if that makes any difference..

    If you would like me to test something, I could do that.

    I have no more ideas for now.

  • I'm doing it like this, to see how GPS works without Google's help.

  • After updating to Android 10, and reset to factory settings, each time I restart, the applications change places.

    The GPS problem is still present in this new update (68).

  • I also think that the problem should be fixed by which when starting the phone for the first time or after a factory reset, the language used by the phone is Italian, you should use English when there is no SIM card installed, or the language that corresponds to the SIM card installed as in any phone.

  • The sound through the headphones connected by cable drops the volume and quality, in the radio application and on YouTube after the last update.

  • Hello @Anders_ASUS

    Is there up-to-date information on all the problems I have put here?

  • I've finally received the test results from one of the units you sent back and it's 100% identical to our standard ZenFone 6 when it comes to GPS and compass performance.

    So it must be something in your area. Or something unique that only you are doing. Could you please try and reset the device, put it in english and do everything like it's not your device. Don't install any app that you would normally install. Test it in other areas and if it works, then you can gradually start to change it into your phone step by step while continuously testing the GPS and compass. Maybe then we can find out what's causing this bug.

  • fjaviergjfjaviergj Level 3
    edited November 2019

    I tried without installing anything (see previous messages). I tried a Zenfone 5z at the same time. The Zenfone 5z works well in my area. The Zenfone 6 seems to have some problem in calculating the position. I tried with Google Maps and HERE We Go, to rule out a mapping problem and it shows the same position error.

    Can the navigation bar be like in Zenfone 5z so they don't take away space on the screen?

  • fjaviergjfjaviergj Level 3
    edited November 2019

    Another bug to fix: the LED does not show notifications during charging.

    Too, with the screen locked, the time left to fully charge the battery is not shown, only fast charging is shown.

  • The night light does not turn off automatically even if it is programmed, if we turn off the device when it is active, and turn it on after the time it should be turned off.

  • edited November 2019

    This is so weird. Your phone is still in spanish though so you didn't do exactly as I said. Probably won't make a difference anyway. I see in both your screenshots that neither of the phones have a locked position and you always make the measurement from the same location. Can you please make a new comparison where the positions on both phones are locked? Btw, which app did you use to measure. I don't believe I've tried this one before.

    This is not a bug but we have several suggestions from users asking us to change this behaviour.

    Could it be that you're using sunset/sunrise instead a set time and have your location turned off?

  • fjaviergjfjaviergj Level 3
    edited November 2019

    Yes, I use the sunset and sunrise. But with the phone on it works correctly. It does not work properly if it turns off after sunset and turns on after sunrise. The phone should check if it has already dawned or evening when turned on to correctly adjust the light. The location is always active, that should not be the problem.

    Regarding the GPS problem, I will try to do more GPS tests in other places and share them here.

    Thanks for the replies. :)

  • https://us.v-cdn.net/6031231/uploads/986/D4B1ZSCOS4EX.mp4 There was an error displaying this embed.

    I think this is a bug. When a battery saver mode is activated (less than 10% battery), each time the device is unlocked, the notification skips as you can see in the video.

This discussion has been closed.